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CHAPTER 1

BEFORE YOU
BEGIN

This section describes the organization and conventions used in this manual. It
also presents an overview of the WordStar menus, commands, cursor move-
ment, and mouse support. It is recommended that you review this information
before you begin using WordStar.
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The instructions in Using WordStar assume that you haven’t changed any of the
original WordStar settings and that you're using pull-down menus (help level 4).
If you need to reinstate the original settings, see “Setting Basic Editing Defaults”
in the Installing and Customizing booklet.

How 10 USE THIS MANUAL

This manual contains step-by-step instructions for learning and using WordStar.
Chapter 2 covers WordStar basics. Chapters 3-9 present common word
processing tasks and the procedures to complete these tasks. Chapter 10 covers
aspects of printing, such as how to change printers and how to set up a file to
print envelopes. Chapter 11 tells how to use MailList™ to create a mailing list
that is used to print form letters. Chapters 1215 tell you how to use merge
printing to perform some special word processing tasks.
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E Sample files are included for use with this manual or during practice sessions.
O The sample files are listed below.

: SAMPLE FILENAME DESCRIPTION

=) LIST.DOC Memo

S SHAKE.DOC Text document

w MAILING.DOC Merge print document

g PLAYBILL.DOC Brochure

= PLAYS.DOC List
Q REVIEW.DOC © Newsletter in two columns

SPELL.DOC Document for spelling corrections

Note: If you want to use a sample file more than once, be sure to close the file
and abandon your changes when you finish working.

CONVENTIONS
The terminology and keyboard conventions described below are used in this
manual.
TERMINOLOGY
Pull-down menus One of two complete sets of menus featured in
WordStar.
Classic menus The original set of menus in WordStar.
Dialog box Contains options for carrying out a command.
Dot command Performs functions mostly related to printing.

Sometimes WordStar inserts a dot command into a
document when you make a choice in a dialog box.
You can also type a dot command directly into a
document. A dot command begins with a period, is
on a line by itself, and takes up no real space in a
document. The period must be in column 1 of the
line followed by the two-letter or three-letter code and
whatever text or setting is required.
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EDITING SCREEN TERMINOLOGY

Title bar Located at the top of the screen. Shows the name of the file
being edited, messages, and prompts.

Menu bar Located on the second line of the screen, below the title
bar. The menu bar displays the names of pull-down menus.

Style bar Located above the ruler line at the top of the screen. The
style bar contains information about current settings as well
as mouse buttons that turn some print enhancements on or

off.

Ruler line Shows current margins and tab settings.

Status line Located at the bottom of the screen when you're editing a
file. It shows the cursor location, messages, and block
markers.

Scroll bar Areas on the screen in which you can use a mouse to move

around in a document. The vertical scroll bar is located at
the right side of the editing area.

Title har————— UWordStar - UNTITLED Menu bar
File [Edit VUieuw Insert Style Layout Utilities <_—|—. Help
Body text fiCourier 18 PC BBEIEUEOOE lﬁ CERE JHtE
S S S — > » ». 'S > ». |

~

Ruler Line Style bar

Scroll bar————

Status line

Insert
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KEYBOARD CONVENTIONS

This manual uses several conventions to describe commands you enter from the
keyboard.

Alt+KEY means hold down the Alt key and press another key.

Alt+KEY1,KEY2 means hold down the Alt key while you press KEY1. Then, you
can release the Alt key or keep it depressed and press KEY2.

AKEY means hold down the Ctrl () key while you press the key assigned to the
command.

AKEYTKEY2 means hold down the Ctrl (*) key while you press the the first key
and then press the second key. (It doesn’t matter whether or not you are still
pressing the Ctrl key when you press the second key.)

The arrow symbol ( =) points to the next item you choose on a pull-down
menu or in a dialog box. For example, File=>Copy means choose the File
menu and then choose the Copy command on the menu. Following the menu
commands, the equivalent key commands are shown in parentheses, for
example, (Alt+F,C).

USING THE MENUS AND DIALOG BOXES

This section explains how to use pull-down menus, classic menus, dialog
boxes, and onscreen help.

PULL-DOWN MENUS AND CLASSIC MENUS

WordStar has two complete sets of menus. They are pull-down menus and clas-
sic menus. The menu choices on both sets of menus perform the same tasks,
but use different keystrokes. The classic menus are designed for touch typists or
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power users who don’t want to take their fingers from the home row of the key-
board. The pull-down menus are designed according to SAA standards.

This manual presents the pull-down menu choices and the equivalent keyboard
commands. Occasionally, commands from the classic menus are recom-
mended, if they require fewer keystrokes.

PULL-DOWN MENUS

The help level setting determines which menus WordStar displays. When the
help level is set at 4, the default setting, you’ll see the pull-down menu bar at
the top of the Opening and Editing screens. This bar displays the pull-down
menus available at that screen.

UordStar

File Utilities Rdditional

Filenames: Path: C:\US 26M free

.. \ | FAX N\ | INSET \ | KAT \
MACROS \ | OPTIONS \ | PIC \ | ARRCUW.HP .3k
BOX .5k | CHEX.HP .5k | CLIENT.DTA .3k | DB@@.DTB 79k
DBO1.DTB 359k | DB@B2.DTB 7?9k | DBB4.DTB 184k | FONTID.CTL 5.8k

INDEX. DTB 44k | KEYBOARD.MRG .1k | LIST.DOC 1.9k | MAILING.DOC 1.8k
NOTE. DOC 1.2k | NOTICE.DOC 1.2k | PLAYBILL.DOC .8k | PLAYS.DOC 1.8k

PLEAD. HP .1k | PREVIEW.MSG 9.9k | PRINT.TST 12k | README.BAT .8k
README. TXT 36k | REVIEW.DOC 3.1k | SHADE.HP .8k | SHAKE.DOC 6.8k
SPELL. DOC 6.1k | VESA1824.UGD 3.8k | WILLY.DOC 1.8k | WINSTALL.HLP 67k
WS.DEF .9k | WUSINDEX.XCL 1.5k | WSMIN.PAT .8k | XXX 6.1k

To display a menu at the Opening screen in help level 4, press the first letter of
the menu name or, if you have a mouse, click the name. You can move
between menus using the Right and Left Arrow keys, the AS and AD commands,
or a mouse. To choose an item on a menu, press the highlighted or underlined
character (depending on what type of monitor you have) or click the item.
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When you open a file, the Editing screen appears.

WordStar - C:\WS\SHAKE.DOC
File Edit Vieuw Insert Style Layout i i

#Body text :

|-——>————>——_->————>____>-——->————>————>-——>————>————>

William Shakespeare

Df all the Elizabethan poets, William Shakespeare is the most
Famous. He uwas born in 1564 in the village of Stratford-on-fivon
o an old and prominent family. His father, John Shakespeare,

as a glover and wool dealer with a shop in Stratford.

Shakespeare entered grammar school in 1571 at the age of seven.
lizabethan education was based on learning by rote, and he had
An excellent aural memory. His education in Latin left an unmis-

takable impression on his vocabulary. In the upper school, he
studied logic and rhetoric, and excelled in dialectic argument, a
kkill he later put to use in his plays. Shakespeare learned

reek mythology and Roman history. When he began to urite, he
shouwed a marvelous ability to make a little knouledge go a long
pay.

Shakespeare married while he was still a minor and needed his
parents’ permission. His bride, Anne Hathauway, uas tuenty-six
Insert P1 L1 ue.s5e" C1 He. 08"

To display a menu from the Editing screen, press Alt and the first letter of a
menu. When the menu appears, choose an item by pressing the highlighted or
underlined character (depending on what type of monitor you have) or by click-
ing the item.

C14SSIC MENUS

When the help level is set at 0, 1, 2, or 3, the classic Opening Menu appears
when you start WordStar. It lists commands for operations such as editing,
printing, and deleting files. For example, the command for opening a docu-
ment file is D.

OPENING MENU

D open a document L change drive/directory
S speed urite (neuw file) C protect/unprotect a file
N open a nondocument E rename a file

P print a file 0 copy a file

\ fax Y delete a file

K print from keyboard F turn directory off

I index a document M macros

T table of contents R run a DOS command

X exit WordStar A additional
F1 help 7 display status
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When you open a file at help levels 2 or 3, the classic Edit Menu appears. (In
help levels 0 and 1 menus are not displayed during editing.) The Edit Menu
contains basic editing commands, including the commands to display the other
classic menus.

EDIT HMENU

CURSOR SCROLL DELETE OTHER MENUS
“E up “W up “G char Fi help ~0 onscreen format
X doun ~Z doun T word 1 tab “K block & save
S left “R screen up Y line “U turn insert off "M macros
“D right “C screen Del char “B align paragraph “P print controls
“A word left doun “U undo “N split the line "Q quick functions
“F word right “L find/replace again

To see the classic menus in help levels 2, 3, or 4, hold down the Ctrl key and
press the command for the menu you want. You can choose any item on the
menu by pressing the appropriate letter.

USING CLASSIC COMMANDS AT PULL-DOWN MENUS

Some people like to see classic commands displayed at pull-down menus. As a
default, classic commands are shown next to the corresponding pull-down com-
mands on the pull-down menus. If you prefer to turn off the display of the clas-
sic commands, press Alt+V,S. Then, in the Screen Settings dialog box, turn off
the setting for Classic Commands on Pull-down Menus. Classic commands
work even when they’re not displayed.

DiaLoc BOXES
When WordStar needs more information to carry out a command, a dialog box
appears. Each dialog box contains one or more areas where you fill in informa-

tion or select settings.

The example following is the Print dialog box.
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List box
Filename: [SBNAENILELIOMNIe L B OK B
Page Numbers: Pages: # Cancel §
¢ All o 0dd
o Selected Pages: o Even
¢ Both
Copies:
[X] Use Form Feeds
Printer: DLGIZNENIL [ 1 Pause Betueen Pages
[ 1 Print Unformatted Text
Redirect To: [N [X1 Interpret Merge Uariables
Printers:
ASC256 | ASCII || DRAFT | us4 o——l
Text box List Check box
List box Option buttons

In a dialog box, you press the Tab key to move forward and Shift+Tab to move
backward. To move directly to an option and select it, press Alt and the key for
the highlighted or underlined character for that option. However, if the cursor
is not in a text box, you can press the key for the highlighted or underlined char-
acter without pressing the Alt key.

To change settings in a dialog box, use these procedures:

® |n a list box, type a name, or press the Down Arrow key to move to the list
and then use the Arrow keys to select a name from the list. You can use the
"R (Repeat) command to repeat the information you entered most recently.

= To select an option button, move to the button for the setting you want. A
diamond shape indicates a selection. If you change your mind, you can
press Alt and the highlighted or underlined character or use the Up or Down
Arrow keys to move to another option button.
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MOVING THE CURSOR AND SCROLLING

= To turn a check box setting on or off, move to the option and press the
Spacebar. To select the item directly, press the key for the highlighted or
underlined character. An X in the brackets indicates that the setting is on.
To clear the check box and turn the setting off, move to the check box and
press the Spacebar or press the key for the highlighted or underlined
character again.

= When you select an option with a text box, you can type the appropriate
information, for example, the number of copies to print. (Some text boxes
may not be long enough for the information you need to type; in this case,
when you get to the end of the box, the information you typed scrolls to the
left and you can keep typing.)

To save the settings and close a dialog box, you can press F10 or, if you have a
mouse, choose OK. (This manual specifies using F10 to close a dialog box, but
AK and Enter are equally acceptable.) To cancel your choices, press Esc or, if
you have a mouse, choose Cancel.

Onscreen help is available for every command in WordStar. To get help at a
pull-down menu, press F1 or choose the Help command on the Help menu.

To get help at a classic menu, press F1 and then the command for which you
want help. To see a list of dot commands press F1 and type a period (.).

MovING THE CURSOR AND SCROLLING

To move the cursor, you can use the direction keys located on the numeric
keypad to the right of the regular keyboard or you can use WordStar com-
mands. (For information about using a mouse to move around in a document,
see “Using a Mouse.”) The direction keys include the arrow keys, the PgUp
and PgDn keys, and the Home and End keys.
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The WordStar commands that move the cursor comprise what is called the
cursor diamond, because of the location of the keys on the keyboard.

CURSOR DIAMOND

DIRECTION KEYS

l
J {jea s

Up one line AEor T
Down one line AXord
Left one character AS or «—
Right one character AD or —
Left one word AA or N~
Right one word AF or A

Scrolling allows you to move another portion of the text onto the screen, either
vertically or horizontally.

Up one line AW or APgUp
Down one line AZ or APgDn
To previous screen AR or PgUp
To next screen AC or PgDn

1-10
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Usinec A MOUSE

In WordStar, the mouse pointer appears on the screen as a rectangle. It appears
when you have a mouse installed on your computer. The pointer does not
appear in the companion programs except for Inset®. You can switch between
the mouse and keyboard at any time.

If you would rather not use a mouse in WordStar, you can turn off mouse sup-
port in the customization program WSCHANGE.

MOUSE CONVENTIONS IN WORDSTAR
Click means to point to an item and press the left mouse button.
Double-click means to point to an item and press the left mouse button twice.

Drag means to hold down the left mouse button while you move the mouse,
and then release the button.

Ctrl+Click means hold down the Ctrl key and press the left mouse button.
Shift+Click means hold down the Shift key and press the left mouse button.

Ctrl+Shift+Click means to hold down the Ctrl key and press the Shift key and
the left mouse button.

MOoVING THE CURSOR AND SCROLLING WITH A MOUSE

The vertical scroll bar, located along the right side of the screen, is for moving
the cursor forward and backward in a document. The vertical scroll bar con-
tains a slider box that indicates the relative position of the cursor in the file.

1-11
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Previous line

Click the up arrow

Next line

Click the down arrow

Previous screen

Click above the slider box

Next screen

Click below the slider box

Beginning of a document

Drag the slider box to the top of the scroll bar

End of a document

Drag the slider box to the bottom of the scroll bar

Approximate page

Drag the slider box to the relative position in the file

WORDSTAR MOUSE SHORTCUTS

Following are some mouse shortcuts.

Change drive/directory

Double-click the directory name

Open document

Double-click the document name

Close a document

Double-click the Close File button in the title bar

Go to page

Click the page number in the status line

Switch windows

Click in the window

Change style

Click the style name in the style bar

Change font

Click the font name in the style bar

Select settings on style bar

Click the button for the setting you want

1-12




CHAPTER 2

LEARNING THE
BASICS

Before beginning the tasks in this chapter, you'll find it helpful to read “Before
You Begin.” It contains important information that will make it easier for you to
learn and practice the basics of word processing with WordStar.

In this chapter you'll learn how to

0 Start WordStar

0 Create a File

0 Edit a Document

0 Name and Save a File

Q Printa File

When you finish this chapter, you’ll be ready to apply these skills to your own
tasks.
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STARTING WORDSTAR

1

In word processing, each document is kept in a file on a disk. You'll follow the
same steps each time you write or edit with WordStar.

To start WordStar:

Look at the DOS prompt to be sure you're in the directory that contains your

WordStar program files (usually WS). If you're not, type cd\ws and press
the Enter key. (If you copied your WordStar program files to another
directory during installation, type c¢d\ and the name of that directory and

press Enter.)

2 Type ws and press Enter.

When you are using WordStar, onscreen help is always available. To get imme-
diate help with what you’re doing, press the F1 key.

THE OPENING SCREEN

Each time you start WordStar, you see the Opening screen.

Melnus

Filenames:

i \
OPTIONS \
CHEX. HP .5k
DBBZ.DTB 73k
KEYBOARD.MRG .1k
PLAYS. DOC 1.8k
README. BAT . Bk
SHAKE. DOC 6.1k
WS. DEF .9k

current directory

current drive
Path: C:\WS 27M free

FAX \
PIC \
CLIENT.DTA .3k

DB@4.DTB 184k
LIST.DOC .9k
PLEAD. HP .1k
README. TXT 36k
SPELL. DOC 6.1k

WSINDEX.XCL 1.5k

INSET
ARROU. HP
DBB@. DTB
FONTID.CTL
MAILING.DOC
PREVIEW. MSG
REVIEU. DOC
UESA1824. UGD
WSMIN. PAT

Menu bar

—

4FllllllllllllIIIlllllllIllIIIIIilIIIFTﬁ;FaSﬁ;;;‘llllllllf::::[___’
File Utilities Additional

\

« 3k

79k

5.8k
1.8k
9.3k
3.3k
3.8k
.8k

Help

MACROS \
BOX .5k
DB@1.DTB 353k

INDEX.DTB 44k
PLAYBILL.DOC .8k

PRINT. TST 12k
SHADE. HP .8k
WINSTALL.HLP 67k
XXX 6.1k

list of filenames
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The menu bar contains the names of the menus you can choose—File, Utilities,
Additional, and Help. Each menu lists commands for performing word process-
ing tasks. To perform a task, you choose a menu and then choose the com-
mand that will perform the task.

Also on the Opening screen is a directory of filenames. This directory lists the
files contained in the current directory on the current drive.

CREATING A FILE

In this chapter, you open a new file, type some text, and then practice editing.
To create a file, first choose the File menu from the Opening screen. Then,
from the File menu, you can create a file.

Note: In the following steps, the arrow symbol ( =) points to the next item you
should choose on a pull-down menu or in a dialog box. For example,
File=>New means choose the File menu and then choose the New command.

7 Atthe Opening screen choose File=>New or press (F,W) to open a new file.

2 Notice that WordStar displays the Editing screen.

WordStar — UNTITLED
Layout Utilities

Insert P1 L1
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The menu bar at the top of the screen contains other menus from which you
can select word processing tasks.

TyPING TEXT

When the Editing screen appears, you're ready to type. Before you begin, you
need to know a few things about word processing.

= The cursor marks your place in the text so you always know where you are
typing on the page.

= You can move the cursor by pressing the direction keys. The direction keys
include the arrow keys, the PgUp and PgDn keys, and the Home and End
keys.

= When you come to the end of a line, WordStar automatically wraps the text
to the next line.

= Press the Enter key twice to start a new paragraph. If you press Enter by
mistake, just press the Backspace key. The cursor moves back to the
previous location.

Now type the following text. (Line lengths may not be the same on your
screen.)

Tryouts for “The Merry Wives of Windsor” will begin on
Thursday. If you’re interested in reading for one of the
principal roles, please sign your name on the sheet posted
backstage. No guest actors have been signed for the
production, so all roles will be filled by members of the
company .

“Merry Wives” will be the tenth anniversary season opener
for the Theatre in the Park series and will be staged at
MacPherson Park Amphitheater. The production is
underwritten by the Morris Corporation, and all proceeds
will go to the Boys and Girls Clubs. Club members will be
admitted free. Following the performance, a fund-raising
gala will be held at the Pavilion, and members of the cast
and crew will be honored guests.
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This open-air production presents extra challenges such as
uncertain weather conditions and background noise, but
similar productions in the past have been received
enthusiastically by audiences and reviewers.

You'll use the text you typed in the remaining sections of this chapter. If you
made any typing errors, you can correct them later when you learn editing
skills. If you’ve made so many errors that you want to start over, choose
File=>Close (Alt+F,C) at the Editing screen. At the Close File dialog box,

press A. WordStar returns you to the Opening screen where you can start again.

EDpITING A FILE

You've now learned how to start WordStar, create a file, and type text. But the
real power of word processing is editing. With the WordStar editing com-
mands, you can correct typos, change wording, insert or delete words, and
much more.

MovING AROUND IN A DOCUMENT

In “Before you Begin” you learned that WordStar has several different ways to
move the cursor in a document. One way is to use the WordStar cursor
diamond commands below. (Hold down the Ctrl key and press the letter.)

= AD (moves the cursor right one character)

= AS (moves the cursor left one character)

= AF (moves the cursor right one word)

= AA (moves the cursor left one word)
Remember, you can also move the cursor by pressing any of the direction keys.

In addition to using the cursor diamond or the direction keys, you can make
quick moves in your document by using the Go to Other command on the Edit
menu.
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To practice moving around in your document, follow the steps below. The
“Merry Wives” file should be displaying on your screen.

1  Choose Edit=>Go to Other=>Document Beginning (Alt+E,O,D) to move the
cursor back to the beginning of the document.

You can use the shortcut ~AEnd to move to the end of a document.

2 Choose Edit=>Go to Other=>Document End (Alt+E,O,O) to move the cursor
to the end of the document.

You can also use the shortcut AHome to move to the beginning of a
document.

TIP |fyou are editing a long document, you can press P at the Edit Menu (or
click Go to Page) and enter a page number. WordStar moves the cursor to the
top of the page you request.

INSERTING TEXT

Before inserting text, look at the status line at the bottom of the screen to see if
Insert mode is on or off. You'll see Insert or Ins-off. When Insert is on, text is
inserted at the cursor location. When Insert is off, text is typed directly over
existing text. WordStar comes with Insert on. To turn Insert off or back on,
press the Insert key. Insert should be on to complete the following steps.

1 In the second paragraph of the “Merry Wives” text, move the cursor to the
“a” in “anniversary” and type annual and press the Spacebar once.

2 Move the cursor to the end of the document. Press Enter twice to start a
new paragraph, and type Plan now to attend.

DELETING TEXT

You can delete individual characters and words or entire lines in WordStar. To
delete a character, press the Del or Backspace key. To delete a word or a line,
follow these steps:
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DELETING A WORD

1 Move the cursor to the “a” in “annual.”
2 Choose Edit=>Delete=>Word (Alt+E,D,W).
The word “annual” is deleted.

DELETING A LINE

1 Move the cursor to the last line of the text.
2 Choose Edit=>Delete=>Line (Alt+E,D,L).

The line of text is erased.

You've probably noticed that classic menu commands appear on the pull-down
menus. A few classic commands provide shortcuts. Two of these shortcuts are
AT (delete a word) and MY (delete a line). If you prefer, you can use the classic
commands. Classic commands generally take fewer keystrokes than pull-down

commands.

RESTORING TEXT

Another handy feature of WordStar is the Undo command. It restores text that
you delete by mistake. To see how it works, delete a line of text and then

restore it.

1 Move the cursor to the beginning of the third paragraph.

2 This time press the shortcut classic command AY to delete the line.
3 Choose Edit=>Undo (Alt+E,U) to restore the line.

The deleted line is back in the text. Single characters erased with the Del
key or the Backspace key cannot be restored with Undo.

TIP You can also restore text with the shortcut classic command *U.
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MovVING TEXT

Moving text in a document is easy when you mark the text as a block.

MARKING A BLOCK OF TEXT

First you mark the beginning and the end of the text you want to move.

7 Move the cursor to the first word in the document “Merry Wives.”
2 Choose Edit=>Mark Block Beginning (Alt+E,B).
3 Move the cursor to the end of the first paragraph.
4  Choose Edit=>Mark Block End (Alt+E,E).
The block of text is highlighted.
MOVING A BLOCK OF TEXT

Now you can move the text to a different place in the document.

1

2

4

Move the cursor to the end of the document.
Choose Edit=Move=>Block (Alt+E,V,B) to move the block.
The entire paragraph moves to the new location.

Move the cursor to the beginning of the document where the paragraph was
originally located.

Repeat step 2 to move the paragraph back to its original location.

REMOVING THE BLOCK HIGHLIGHTING

You can remove the highlighting from a block of text by following these steps:

1

2

Choose View=>Block Highlighting (Alt+V,B).

Notice that the block of text is no longer highlighted.
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ADDING BOLD EMPHASIS

You can add special printing effects, such as bold or italic, to text.

NT

1 In the first paragraph of the “Merry Wives” text, move the cursor to the first

quotation mark in “The Merry Wives of Windsor.”
2 Choose Style=>Bold (Alt+S,B) to begin bold.

3 Move the cursor to the space following the second quotation mark and
repeat step 2. The entire title is now bold.

VIEWING COMMAND TAGS

When you tell WordStar to insert a special printing effect, command tags
appear on the screen where you turn the special effect on and off. For
example, when you add bold to text, the WordStar command tag ~B appears
on either side of the bold text. You can turn the command tags display off so
you can see more clearly what your document looks like.

1 Choose View=>Command Tags (Alt+V,C).

Notice that the print command tags are no longer visible; however, the
commands are still in effect.

TIP  You can use the shortcut classic command ~OD to turn the
command tags display on or off.

2 Repeat step 1, or use ~OD, to turn the command tags display back on.

NAMING AND SAVING A DOCUMENT

When you create a new document with File=>New (F,W), you give the file a
name when you save it. Once a file is named and saved, you can retrieve it

any time to read or edit it.

at
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A filename can contain from one to eight characters, including letters and num-
bers. You can also add a filename extension to the eight-character name. A
file extension is a period followed by three characters.
Now name and save your “Merry Wives” document.
1 Choose File=Save and Close (Alt+F,L).

The Save As dialog box appears.
2 Type notice.doc in the Filename box.
3 Press F10 or choose OK to close the dialog box.

You have typed, edited, named, and saved the document.

The filename NOTICE.DOC is now listed in the directory display.
T'IP  When you create a filename, think of a name that will remind you of the
contents of your document. For example, if you are writing a letter to a client
named Smith, you might name your file SMITHLTR. The extension could be a
date reminder. If you wrote the letter on June 16, the entire filename could be

SMITHLTR.616. You can use the numbers 1-9 for January through September
and the letters O, N, and D for October, November, and December.

PRINTING A DOCUMENT

If you have installed a printer, you can print your document. Now you'll print
NOTICE.DOC.

1 Atthe Opening screen, choose File=>Print (F,P).
The Print dialog box appears. This is where you tell the printer what to print

and how to print it. Most of the time you won’t need to change any of the
information shown.

2-10
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Filename: [SHNISNIN {83

Page Numbers: Pages: % Cancel
+ All o 0dd
o Selected Pages: o Even
¢ Both
Copies:

[X] Use Form Feeds
Printer: [[JENA [-1 Pause Betueen Pages
[-] Print Unformatted Text

Redirect To: |GG [X] Interpret Merge Variables

NOTICE.DOC is the file you just saved and want to print.

2 Press F10 or choose OK to begin printing the file.

OPENING AN EXISTING FILE
To open the NOTICE.DOC file, follow these steps:
1  Atthe Opening screen choose File=>Open Document (F,D).
The Open dialog box appears.

2 Type notice.doc and press F10 or choose OK. You see the NOTICE.DOC
file on the Editing screen.

TI1P Besides typing the name of the file that you want to open, you can
select the file in other ways. If you have a mouse, click on the filename in
the list of files. Or use the direction keys to move the cursor to the filename
and press Enter.

3 Choose File=>Save and Close (Alt+F,L) to save any editing changes and
close the file.
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REVIEWING THE BASICS

You've covered the basics of word processing. For most word processing tasks
you follow these steps:

1 Start WordStar.
2 Create or open a file.
3 Type or edit text.
4 Name and save the file.
5 Print the file.
Now you are ready to move on to the next chapter and learn how to format

your documents. If you want to stop here and leave WordStar, choose
File=>Exit WordStar (F,X).



CHAPTER 3

FORMATTING
WITH PARAGRAPH
STYLES

In this chapter, you’ll learn about

0 Using Paragraph Styles to Format a Document

(]

Selecting Paragraph Styles

0 Preparing a List with a Hanging Indent
O Viewing Style Settings

U Previewing a Document

Formatting determines how a document will look when it’s printed. The easiest
way to format a document in WordStar is to use paragraph styles.

In this chapter, you’ll learn how to use the paragraph styles that come with
WordStar. After you format and edit a document, you’ll preview the printed file.
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USsING PARAGRAPH STYLES

A paragraph style stores layout settings such as margins, tabs, line spacing, and
font changes. When you select a paragraph style, all the text settings contained
in that style are inserted into your document.

SELECTING THE TITLE STYLE

All WordStar documents use the Body Text style until you specify another style.
The Body Text style contains the default WordStar settings for margins, tabs,
line height, and so on. Body Text sets a left margin of 0 inches and a right
margin of 6.5 inches, and starts the first line at the left margin.

In the following steps, you’ll choose another style to change the look of a memo.
17 Open the file LIST.DOC.

If you need help, see “Opening an Existing File” in the “Learning the Basics”
chapter.

You'll use the Title paragraph style to center the word “MEMO,” make it
bold, and give it a larger font.

2 With the cursor on the first letter of “MEMO,” choose Style=>Select
Paragraph Style (Alt+S,S).

3 When the list of styles appears, select the Title style. You can either
type Title or move the highlighting to Title. Press F10 or choose OK. If
you have a mouse you can double-click Title.

The Title style command tag is inserted at the cursor location. The style bar

shows that Title is the current paragraph style. The text is now bold, centered,
and prints in a larger font.

SELECTING BODY TEXT
You want the text after “MEMO” to return to the default Body Text settings.

1 Move the cursor to the beginning of the line below “MEMO.”
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USING PARAGRAPH STYLES

Choose Style=>Select Paragraph Style (Alt+S,S) to select a paragraph style.

TIP If you have a mouse, you can click on the style name in the style bar
to select a new paragraph style.

When the list of styles appears, select the Body Text style. You can type
Body Text or move the highlighting to Body Text. Press F10 or choose OK.
If you have a mouse, you can double-click Body Text.

The text following the Body Text command tag is no longer highlighted because
bold is turned off. The original text settings are now in effect.

PREPARING A LIST WITH HANGING INDENT 1

To practice using the Hanging Indent 1 paragraph style, you'll prepare a list of
props for the “Merry Wives of Windsor.” The Hanging Indent 1 style formats
text for a numbered list. The numbers are typed at a left margin of 0 inches and
the text wraps at a left margin of .5 inch.

1

Move the cursor one line below the sentence that begins “Please prepare
the props...”

Choose Style=>Select Paragraph Style (Alt+S,S).

When the list of styles appears, select Hanging Indent 1. Press F10 or
choose OK. The Hanging Indent 1 command tag is inserted into the
text area.

Press Enter to move the cursor down one line.

Type 1. and press the Tab key. The number is typed at the left margin of 0
inches. The Tab key indents the cursor to .5 inch.

Type the following text:
Small rustic table and three rustic chairs to be placed on

a slightly raised platform stage right. The scene is set
on the street outside the tavern.

The text wraps to a .5 inch left margin.
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7 Press Enter twice. Type 2. and press the Tab key.
8 Type the following text:

Sturdy laundry basket large enough to carry Falstaff. It
will be easier for the actors to carry the basket if it’s
slung on poles.

In the list, the numbers are typed at the 0-inch first line indent. When the text
wraps, it wraps at the .5 inch margin.

Note: Two other styles, Hanging Indent 2 and Hanging Indent 3, format text in a
similar way. Hanging Indent 2 formats the first line of a paragraph at .5 inch and
subsequent lines at 1 inch. Hanging Indent 3 indents at 1 inch and 1.5 inches.

This is how your document will look when you print it.

MEMO

To: Charles
From: Deborah
Re: Props

Rehearsals for Act I of “The Merry Wives of Windsor” are sched-
uled to begin on Monday. During the first week, while we’re
blocking the action, I’d like to have a small table and three
chairs on stage. We’re performing this play in settings and
costumes from the 1920s. For the performances, you’ll need to
prepare props that are appropriate for that period. 1I‘m giving
you advance notice because some of the props could be difficult
to find or comstruct.

Please prepare the props listed below for “Merry Wives.”

1. Small rustic table and three rustic chairs to be placed on a
slightly raised platform stage right. The scene is set on
the street outside the tavern.

2. Sturdy laundry basket large enough to carry Falstaff. It
will be easier for the actors to carry the basket if it’s
slung on poles.
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VIEWING STYLE SETTINGS

You can look at the settings of any style.

1

2

Move the cursor to the line below the Hanging Indent 1 style command tag.

Choose Style=>Define Paragraph Style (Alt+S,D) to view the settings of a
paragraph style.

You see the settings for the style currently in effect, which is Hanging Indent 1.
Notice that the left margin is set at .5 inch and the first line indent (first line
of each paragraph) is set at 0 inches.

Press Esc to close the Define Paragraph Style dialog box.

Move the cursor so that it immediately follows the Body Text command tag.

Repeat step 2 to choose Define Paragraph Style.

The WordStar default settings are in effect. For example, bold is off,
centering is off, and the default font is used.

Press Esc to close the dialog box.
Move the cursor to immediately follow the Title style tag. Repeat step 2 to
view the style settings. The Title style is centered and bold. Also, if you

have a large font, it will be used.

Press Esc to close the dialog box.

PREVIEWING A DOCUMENT

You can see how the printed list will look by using the Preview command.
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1 Choose View=Preview (Alt+V,P) to choose Preview.
TIP You can also use Alt+1 to choose Preview.

A preview of the printed page appears. The title is bold, centered, and in a
larger font. The numbered list is indented.

2 Choose View=>2 to magnify the page to twice its size.
3 Use the direction keys to move the view to other parts of the page.
4 Try some of the other commands in Preview.

5 When you're finished, choose Exit=>QOriginal page to exit Preview and
return to the page where you started Preview.

TIP Preview is useful if you have a long document. You can preview
several pages and return to your original cursor location. You can also
press Esc to return to the original page. In Preview, if you choose
Exit=Current page, you return to edit the page that you're currently
previewing.

Follow the steps below to close the file.

7 Choose File=>Close (Alt+F,C) to close the file without saving it.

2 Inthe Close File dialog box, press A to select Abandon.

The file is closed without saving the changes and you’re returned to the
Opening screen.

The next chapter, “Editing Paragraph Styles,” contains information about creat-
ing and editing paragraph styles.



CHAPTER 4

Eprring
PARAGRAPH STYLES

In this chapter you'll learn about

L Storing Paragraph Styles

I Creating Paragraph Styles

O Editing Paragraph Styles

I Inheriting Style Settings

In the chapter “Formatting with Paragraph Styles” you learned how to select
paragraph styles and apply them to your text. In this chapter, you'll learn how

WordStar stores paragraph styles, how to create and change styles, and how to
inherit style settings.

How PARAGRAPH STYLES ARE STORED

Before you learn how to create and change paragraph styles, you need to under-
stand how they are stored. Paragraph styles are stored in two places—in the
style library and with the document using the styles. Styles stored in the library
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are called library styles. Styles stored with the document are called document
styles.

A library style can be selected in any document. (The predefined styles you

used in Chapter 2 are examples of library styles.) A document style can be used
only in the document in which it is stored. When you choose a library style,
WordStar inserts a copy of that style into your document. The inserted style stays
with that document; the library style is still available for use in other documents.

In the following chapters, you'll create a style and save it as both a document
style and a library style. Then you’ll change the style and save the changes to
the document style only. You’ll then have two versions of the style: the
original library version and a document version that is slightly different.

C REATING PARAGRAPH STYLES

Paragraph styles are helpful in creating customized documents. A resume is an
example of a customized document that requires special formatting.

Follow these steps to create a paragraph style that can be used in a resume:
1 At the Opening screen, choose File=>New (Alt+F,W) to open a new file.

2 Choose Style=>Define Paragraph Style (Alt+S,D) to create a paragraph style.
Define Paragraph Style

Style: PR Left Margin: QSECTHE
ist Line Indent: il
I ElCourier-16-PC [ Right Margin: SN
Leading: (Line Height) Line Spacing:
Tabs: §
On Off Inherit Alignment: ¢ Flush Left
Bold o * o o Centered
Italic o * o o Flush Right
Underline o * o o Justified
Strikeout o ® o o Inherited
Doublestrike o ¢ o
Superscript o . o ColorsShading: [N
Subscript o * o
Word Wrap ¢ o o [-1 Update Style Library

e s e e LG T SR RS £ s o L S e N B 1 P e
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3 In the Style box, type Name and Address.

4 Change any other settings that you want. For example, you might want to
select a larger font to make the text stand out or bold or center your name
and address.

Note: You can use the Tab key to move between options in a dialog box, or
you can press the Alt key and the key for the underlined or highlighted
character in the option name. For example, press Alt+U to move to the
Underline box in the Define Paragraph Style dialog box. If the cursor is at
an option button or check box, you can just press the key for the underlined
or highlighted character without pressing the Alt key.

5 Press Alt+Y to update the style library.

6 Press F10 or choose OK to save the new style.

WordStar saves the style in both the document and the style library. The
new style is now available for any WordStar document.

Follow these steps to use the new style in your document:
1 Choose Style=>Select Paragraph Style (Alt+S,S).
2 Select the new style.
WordStar inserts the Name and Address style tag into your document.

3 Type the text for your name, address, and phone number. The new style
settings will be in effect when you print your document.

William Shakespeare
12345 Valley Glenn Lane
London, England
(123) 456-6789
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E DITING PARAGRAPH STYLES

You can change the settings in an existing paragraph style by editing that style.
For instance, if you want different settings in the Heading style, you can change
them and then save the style. The new settings will be in effect when you
select the Heading style for your document.

In this section, you'll change an existing style to create a style for a heading in a
resume.

Follow the steps below to change the settings in the Heading style and then
save the style to the document. Later, if you decide you want to use the style in
other documents, you can copy the style to the library.

1 Choose Style=>Define Paragraph Style (Alt+S,D). The settings for the current
style appear in the dialog box.

2 Select the Heading style.

3 Change any style settings that you want for your resume heading. For

example, the current Heading style turns on both bold and underline. You
may want to use bold and turn off underline.

4 Press F10 or choose OK to save the new settings.

This style will be saved in the document, but not in the library because you
did not select the Update Style Library check box.

You now have two versions of the Heading style—your document version and
the original library version. If you turned off underline, the document version
has no underlining. However, the library version keeps the original underlining.
Now you can insert the new heading style into your document.
1 Choose Style=>Select Paragraph Style (Alt+S,S) to select a style.

2 Select Heading.

The Heading style is inserted into your document.
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3 Type the heading EMPLOYMENT HISTORY.

William Shakespeare
12345 Valley Glenn Lane
London, England
(123) 456-6789

EMPLOYMENT HISTORY

Freelance writer for the past 20 years.

4 Save the file.

As you create your own library of paragraph styles, you'll find that paragraph
styles make formatting easy and help maintain consistency in document for-
mats. You may decide, for example, that you want to use the new document

style, Heading, for other resumes. You could then save that style to the library
and use it again.

INHERITING STYLE SETTINGS

Each paragraph style contains its own settings for margins, fonts, and so on.
When you insert or select a style, all of its settings override the previous style
settings.

WordStar has a feature that allows you to use or inherit settings from previous
styles. For example, if you want to use the same font throughout a document,
you select a font for the style now in effect at the beginning of the document.
Then, each time you add another style to the document, you clear the Font box
for that style. The styles with blank font boxes inherit the font from the first style.

In the following steps, you'll create a style that contains a new font. Next,
you'll insert the style into your document. Finally, you’ll create and select a
style that inherits a font.
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Open a file that contains at least two paragraphs of text, for example, the
sample file SHAKE.DOC.

With the cursor at the beginning of the file, choose Style=>Define Paragraph
Style (Alt+S,D).

The settings for the Body Text style appear.
Press the Tab key to move to the Font box.
Select a font that you want to appear throughout the document.

Press F10 or choose OK to save the style to the document (but not to
the library).

Choose Style=>Select Paragraph Style (Alt+S,S) and select the Body Text
style.

The Body Text style with the new font is now in effect at the beginning of
the document.

You want your next style to inherit the font from Body Text.

1

2

Move the cursor to the beginning of the second paragraph.

Choose Style=>Define Paragraph Style (Alt+S,D) and select the Paragraph
Indent style.

Press the Tab key to move to the Font box.

Press the Spacebar to clear the Font box.

Note: When a paragraph style option is blank, it inherits settings from the
previous style. You can select the Inherit option for some style settings. For
example, Bold has three option buttons—On, Off, and Inherit.

Save the style to the document but not to the library.

Choose Style=>Select Paragraph Style (Alt+S,S) and select the Paragraph
Indent style.

The style is inserted into the document.
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The Paragraph Indent style inherits the font from Body Text. The second
paragraph is reformatted with the new style settings.

Any subsequent paragraphs need to be reformatted with the new font size.

1

Choose Utilities=>Reformat=>Rest of Document (Alt+U,R,R).
TIP  You can also reformat with the shortcut classic command "QU.
Now you can preview the document to be sure it's been reformatted.

Choose View=>Preview (Alt+V,P) to preview the printed page. The entire
document will be displayed (and printed) with the new font from Body Text.

Press Esc to exit Preview.

Close the file.

If you want to close the file and save your changes, choose File=>Save and
Close (Alt+F,L). If you want to close the file without saving your changes,

choose File=>Close (Alt+F,C). In the Close File dialog box press A to
abandon changes.



CHAPTER 5

WORKING wWiITH
BLOCKS OF TEXT

In this chapter, you’ll learn about

1 Copying a Block to Another File

1 Copying Text Between Windows

1 Copying Text To and From the Clipboard

1 Converting Text to Uppercase

In this chapter, you learn how to copy a block from one file to another, how to

use the Microsoft Windows Clipboard to copy and move blocks, and how to
convert text in a block from lowercase to uppercase.

COPYING A BLOCK TO ANOTHER FILE

You may want to copy part or all of a file to another file. You can mark the text
as a block and then copy it to a new or existing file. The original document still
contains the block of text that was copied.
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To copy a block of text to another file, follow these steps:
1 Open an existing WordStar file.

2 Mark a block of text to copy.

3 Choose Edit=>Copy=>To Another File (Alt+E,C,A).

4 Type a new filename and press F10 or choose OK.

The block is copied to a new file. Now, by using windows you can easily
copy the text to a file that you're editing.

5 Close the file.

The next section describes how to copy blocks of text between windows.

EDITING IN WORDSTAR WINDOWS

While you're editing one file in WordStar, you can open another file at the
same time. The screen splits and you can see both documents on the screen at
the same time. This is handy for editing two documents because you can move
text between them. You can also split the screen to look at two different parts
in the same document.

In this section you’ll open one file, then open another file and work with both
files at the same time.

OPENING TWO WINDOWS

1 Atthe Opening screen, choose File=Open Document (F,D) and open an
existing document.
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2 Atthe Editing screen, choose File=Open/Switch (Alt+F,W).

If your computer doesn’t have enough memory to open a second window,
an error message appears.

3 In the Open Document dialog box, select another file to open. Press F10 or
choose OK.

Your screen looks like this:

WordStar - C:\WS\PLAYBILL.DOC
Insgrt Style Layou; iliti

William Shakespeare

0f all the Elizabethan poets, William Shakespeare is the most
ifamous. He was born in 1564 in the village of Stratford-on-Auvon
to an old and prominent family. His father, John Shakespeare,
was a glover and wool dealer with a shop in Stratford.

iShakespeare entered grammar school in 1571 at the age of seven.

[Elizabethan education was based on learning by rote, and he had
e o e S g e S
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THEATRE IN THE PARK
PERFORMANCES

TENTH ANNIUERSARY SEASON

GALA OPENING

ug. 58"

Insert P1 L1 Cc1

Notice that the ruler line for the second file separates the two windows. The
number 2 in the title bar indicates that the cursor rests in the second
window. Although you can see both documents, you can edit only the
document in the window with the cursor.

4  Choose File=Open/Switch (Alt+F,W) to move the cursor to the other
window.
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Now the cursor is in the other window. You can edit text in this file. The
status line, style bar, and title bar apply to this window.

TIP If you have a mouse, you can click in either window to move the cursor
to that window.

COPYING TEXT FROM ONE WINDOW TO ANOTHER
You can copy or move a block of text from one window to another.
1 Mark a block of text in one of the windows.

2 Choose File=>Open/Switch Window (Alt+F,W) to move the cursor into the
other window.

3 Move the cursor to where you want to copy the block.

4  Choose Edit=Copy=>Block from Other Window (Alt+E,C,O) to copy the
block from the other window.

The block is copied at the cursor location. Any text that was at the cursor
location now follows the block.

CHANGING THE SIZE OF THE CURRENT WINDOW

You can change the size of the current window (the window containing the
cursor). Follow the steps below to reduce the size of the window.

1 Choose View=>Change Window Size (Alt+V,W).

2 In the Change Window Size dialog box, press the Down Arrow key to select
Lines.

3 Type 3 to change the window to three lines (the ruler line is considered one
line). Press F10 or choose OK.

The windows now look like this:
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Tryouts for "B"The Merry Wives of Windsor'”B will begin on Thursday.
If you’re interested in reading for one of the principal roles,

Chronology of the Plays

1591-92
Henry UI

1592-93
ﬁichard III
omedy of Errors

15393-94
Titus Andronicus
Taming of the Shreu

1594-35
Tuo Gentlemen of Uerona
Love’s Labour’s Lost

Note: If you choose Full Screen in the Change Window Size dialog box, the
current window takes over the whole screen. When you move the cursor
between windows, the screen changes from one document to the other. The
title bar shows the name of the file you’re working in.

CLOSING THE WINDOW

When you want to return to the Opening screen, you close the windows one at
atime. (You don’t need to save any changes to the current files.)

Use the following steps to close the window where the cursor is located.
1 Choose File=>Close (Alt+F,C).

The Close File dialog box appears.
2 Press A to close the file without saving it.

You've closed the window and the cursor is in the second file.

3 Repeat steps 1T and 2 to close the file without saving it.
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C OPYING A BLOCK TO AND FROM THE CLIPBOARD

If you are running WordStar in Microsoft Windows, you can use the Windows
Clipboard to copy or move text from WordStar to another software program.
When text is copied from WordStar, it's converted to ASCII format (the
WordStar control characters and dot commands are stripped from the text).

You can also copy text from another program to WordStar. Only ASCII text can

be copied from the Clipboard into WordStar. If the Clipboard contains graphic
images or an unrecognizable format, WordStar warns you that the text can’t be

copied.

You can copy to and from the Clipboard only when Windows is running in
enhanced mode on a 386-based system.

In the following steps, you copy text from WordStar to the Clipboard, and then
from the Clipboard to another program.

1 Start WordStar in Microsoft Windows using 386 enhanced mode.
2 Open an existing WordStar file.
3 Mark a block of text to be copied to a file in another program.

4 Choose Edit=>Copy=To Windows Clipboard (Alt+E,C,T) to copy the block
to the Windows Clipboard.

5 Close the file.

6  Start a word processing program that accepts ASCII text from the Windows
Clipboard.

7 Open the file to which you want to paste the WordStar text.
8  Paste the WordStar text from the Clipboard.
The WordStar text is now inserted into the other file.

Now you’ll copy text from the current file to the Clipboard. Then copy the text
from the Clipboard into a WordStar file.
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Copy text to the Clipboard.

Close the file and exit the program.

Start WordStar and open a file.

Move the cursor to where you want to copy the text from the Clipboard.
Choose Edit=>Copy=>From Windows Clipboard (Alt+E,C,F).

The text from the other word processing program is copied into your
WordStar file.

Close the WordStar file. If you don’t want to save the changes, abandon the
file.

CONVERTING A BLOCK TO UPPERCASE

You may decide that you want to change all the letters in a block to uppercase
or lowercase. Instead of retyping all the text, you can convert it with a
WordStar command. In the steps that follow, you'll convert some text from
lowercase to uppercase.

1

2

Open a file that contains lowercase letters.

Mark the block of lowercase text that you want to convert. If you need help
in marking a block, see the chapter “Learning the Basics.”

Choose Style=>Convert Case=>Uppercase (Alt+S,C,U) to convert to
uppercase.

All the text in the block is now uppercase.

Close the file. If you don’t want to save the changes, abandon the file.



CHAPTER 6

EDITING A LONG
DOCUMENT

In this chapter you’ll learn about

o

Headers and Footers

1 Using Footnotes

5

Setting Margins

)

Finding Text

(W]

Checking Spelling

3

Finding Synonyms

WordStar has features that are especially helpful for creating and editing long
documents. In this chapter you'll be introduced to these features.



EDITING A LONG DOCUMENT

HEADERS AND FOOTERS

Headers are special lines of text printed at the top of every page; footers are spe-
cial lines of text printed at the bottom of every page. Headers and footers can
include page numbers and other information such as a chapter title.

The command for a header is Layout=>Headers/Footers=>Header (Alt+L,H,H).
The command for a footer is Layout=>Headers/Footers=>Footer (Alt+L,H,F).

This chapter does not contain steps for creating a header because, except for
the command, you follow the same steps to create a header as you do to create
a footer.

In the following steps, you'll create a footer containing a chapter name and
page number.

1 Open the file SHAKE.DOC.

2 With the cursor at the beginning of the file, choose Layout=>Headers/
Footers=>Footer (Alt+L,H,F).

The Footer dialog box appears.
3 Press the Spacebar to select a one-line footer.
4 Press F10 or choose OK.

WordStar inserts the dot command .f1 for a one-line footer.
5 Type Chapter 1.

6 Use the Spacebar or Tab key to move the cursor further to the right of the
footer text.

7 Type Page #.

When you print the document, the page number will appear in place of the
# symbol.

Now you can view the footer with Preview.
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USING FOOTNOTES

Choose View=>Preview (Alt+V,P).
Notice the footer at the bottom of the page.

Press PgDn to move to the next page. The footer appears on each page and
gives the correct page number.

Press Esc to exit Preview.

Close and abandon the file.

TIP A footer can contain up to five lines. If you want a footer with more
than one line of text, you need to enter another footer command. WordStar
will print the footer on each page. If you want a footer only on odd or only on
even pages, you select the appropriate option in the Footer dialog box.

Usine FOOTNOTES

With WordStar you can create footnotes, endnotes, and annotations. Footnotes
are automatically ordered and printed at the bottom of the page where the refer-

ences ‘occur.

In the following steps, you create a footnote.

1

2

Open the file SHAKE.DOC.
Move the cursor to the end of the first paragraph (after “Stratford”).
Choose Insert=>Note=>Footnote (Alt+I,N,F).

Type the following text:

For more information on John Shakespeare, see The Families
of Famous Playwrights by Henry Drummer.

Choose File=>Save and Close (Alt+F,L) to save the note.
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You're back at the Editing screen. With View Command Tags on, the first
few words of the footnote appear in brackets. With Command Tags off,
references to footnotes (numbers beginning with 1) appear in the text.

Now use Preview to see how the printed footnote will look.

1 Choose View=>Preview (Alt+V,P).
The footnote appears at the bottom of the page.

2 Press Esc to exit Preview.

3 Close the file and abandon your changes.

To remove a footnote, delete its reference (number, letter, or symbol) or delete

the command tag. If you delete a reference accidentally, you can restore it with
the Undo command. The classic command for Undo is AU.

SETTING MARGINS

You can set left and right margins, first line indent, and tab stops using the Ruler
Line dialog box.
LEFT AND RIGHT MARGINS

In this exercise, you'll change the left and right margins. When you change the
margins in a document, the new settings override the previous margins set by
paragraph styles or dot commands.

1 Choose File=New (F,W) to open a new file.

2 Type some text that wraps to the next line and uses the default left and right
margins. Press Enter at the end of the text.

3 Choose Layout=>Ruler Line (Alt+L,R).

The left margin is set at 0 inches and the right margin is set at 6.5 inches.
The cursor is in the Left Margin box.
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4 Type .5 for the left margin.
WordStar adds the “ symbol for inches. For example, if you type .5, the dot
command .Im .5" is inserted into the document. If you need more
information about dot commands, see "Before You Begin.”

5 Press Alt+R to move to the Right Margin box.

6 Type 4.5 for the right margin.

7 Press F10 or choose OK to save your changes.

WordStar inserts dot commands for the left (.Im) and right (.rm) margins.

8 Type some text below the dot commands and notice that it wraps at the new
margins.

Your screen should look like this:

WordStar — UNTITLED
Insert Style Layout Utilities

ou can set left and right margins, first line indent, and tab
istops by using the Ruler Line dialog box.
.1m

Nou the margins are different and the
text wraps at different places on the
screen.

9 Close and abandon the file.
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TopP AND BOTTOM MARGINS

In the next steps, you'll change the top and bottom margins, using Preview to
see the before and after effects.

1 Open SHAKE.DOC.

2 Choose View=>Preview (Alt+V,P) and notice the default top and bottom
margins of the printed page. The default top margin is .5 inch and the
default bottom margin is 1.5 inches.

3 Press Esc to exit Preview.

4 Choose Layout=>Page (Alt+L,P).

The Page Layout dialog box appears.

5 Press Alt+T to move to the Top Margin box.

6 Type 1.5 for the top margin.

7 Press Alt+B to move to the Bottom Margin box.

8 Type .5 for the bottom margin.

9 Press F10 or choose OK to save your changes.

Now view the document with the new top and bottom margins in
Preview.

1 Choose View=>Preview (Alt+V,P). The new top and bottom margins
appear.

2 Press Esc to exit Preview.

3 Close the file and abandon your changes.
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Finpine TEXT

WordStar can find up to 68 characters of text, including individual words,
groups of words, numbers, and symbols. Locating words or phrases can be
helpful when you're editing or when you want to find a particular place in a
large document.

Use the following steps to ask WordStar to find some text.

1 Open SHAKE.DOC.

2 Choose Edit=Find (Alt+E,F).

3 Inthe Find dialog box, type Shakespeare as the text to find.

“
Find: |

Options:
Search:
¢ For Next Occurrence [-1 Whole Words
o Entire File/Global [-1 Ignore Case (W
[-1 Backuard
Occurrence [JH [-1 Use 7 Wildcard Character

hakespeare entered grammar school in 1571 at the age of seuven.
Elizabethan education uas based on learning by rote, and he had
Bn excellent aural memory. His education in Latin left an unmis-—
takable impression on his vocabulary. In the upper school, he
studied logic and rhetoric, and excelled in dialectic argument, a
skill he later put to use in his plays. Shakespeare learned
Greek mythology and Roman history. When he began to urite, he
showed a maruelous ability to make a little knouwledge go a long

ay.

Shakespeare married while he was still a minor and needed his
Insert P1 L1 UB.50"

C1

4 Press F10 or choose OK.

The cursor moves to the first occurrence of Shakespeare.
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FINDING THE NEXT OCCURRENCE
You can also ask WordStar to find the next occurrence of the text.
1 Choose Edit=>Next Find (Alt+E,X).
The cursor moves to the next occurrence of “Shakespeare.”

TIP You can also use the shortcut classic command AL to locate the next
occurrence of text.

2 Press AL to locate the next occurrence of text. Continue to press AL until
you reach the end of the file.

FINDING AND REPLACING TEXT

WordStar can find text and replace it with other text. This is helpful when you
want to change every occurrence of a word or phrase.

1 Choose Edit=>Find and Replace (Alt+E,R).
2 In the Find box, type Stratford and press the Tab key.

3 Inthe Replace box, type London and press the Tab key. The cursor moves
to the Options box.

In the following steps, you'll tell WordStar to replace all occurrences of “Strat-
ford” with “London.” You’ll also tell WordStar not to ask for confirmation every

time it finds “Stratford.”
1 Press Alt+G to search the entire file.

The cursor moves to the check box and the option is selected.

2 Press Alt+N to check Don’t Ask (replaces without asking).




CHECKING SPELLING

ST G R PRSI Find and Replace [Sst= tcemer e oe e A

Find: SEEg

Replace: Cancel
Options: RN
[X1 Align
Search: [X1 Don’t Ask
o For Next Occurrence [ 1 Whole Words
¢ Entire File/Global [ 1 Ignore Case (WD
o Rest of File [ 1 Maintain Case
[ 1 Backuard
Replace [l Occurrences [ 1 Use 7 Wildcard Character

3 Press F10 or choose OK.
All occurrences of “London” are replaced with “Stratford.”
4 When WordStar reaches the end of the file, press Esc.
5 Close the file and abandon your changes.
You can use the find feature in a variety of ways. In addition to forward or

backward searches and manual or automatic replacements, WordStar can
search for parts of words, for specific case (upper- or lowercase), and more.

CHECKING SPELLING

WordStar can find and correct misspellings and typos. The spelling check fea-
ture checks the spelling of an entire document, the rest of a document begin-
ning at the current cursor location, or a single word. In this section, you'll learn
how to check the spelling of an entire document.

WordStar checks the spelling against a large dictionary, which was copied onto
your hard disk when you installed WordStar.
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You have another dictionary called the personal dictionary. As you use the
spelling checker, you can add to your personal dictionary those names and
words that aren’t in the main dictionary. WordStar checks spelling against both
dictionaries.

CHECKING THE SPELLING OF AN ENTIRE DOCUMENT
Follow the steps below to run a spelling check.
1 Open the file SPELL.DOC.
2 Choose Utilities=>Spelling Check Global (Alt+U,S).

The cursor stops on the first misspelled word, “famus.” WordStar offers
correct spelling suggestions.

Spelling Check
Word: famus

Suggestions: 1 famous 2 fames 3 foams 4 fumes
Global Replacement is off
Ignore/Check Next Word Enter Correction
Add to Personal Dictionary Bypass This Time Only
Esc Cancel

— > > > > >

William Shakespeare

Of all the Elizabethan poets, William Shakespeare is the most
Fanus. He uwas born in 1564 inth village of Stratford-on-Avon to
an old and prominent family. His father, John Shakespeare, uwas a
glover and wool dealer with a shop in Stratford.

Shakespeare entered grammar school in 1571 at the age of seven.
Elizabethan education was based on learning by rote, and he had
an excellent aural memory. His education in Latin left an unmis-—
takable impression on his vocabulary. In the upper school, he
studied logic and rhetoric, and excelled in dialectic argument, a
Insert P1 L1 UB.58" C1

3 Press 1 to replace the incorrect word with the correct spelling.

WordStar stops at the next misspelled word, “inth.”

6-10
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CHECKING SPELLING

None of the suggested words are appropriate so press E to enter a correction.
Type in the in the Spelling Correction dialog box. Press F10 or choose OK.
The speller stops at the next misspelled word, “glover.”

The spelling checker stops on words that aren’t in the main dictionary.
Sometimes these words are spelled correctly (like “glover”) but aren’t
common enough to be in the dictionary. You can add such words to your
personal dictionary so the spelling checker doesn’t stop on them in the
future.

Press A to add “glover” to the personal dictionary.

The next time WordStar comes across this word, it will not be flagged as
misspelled.

WordStar stops on the next misspelled word, “Susanna.”
Press | to ignore “Susanna” and then press | again to ignore “Hamnet.”

“Susanna” and “Hamnet” will be ignored throughout the rest of the file.
WordStar stops on the next misspelled word, “Lucrece.”

Press M to see additional suggestions.

When all suggestions have been displayed, WordStar returns to the first
group of suggestions.

Press Esc to stop the spelling check. You can do this at any time during a
spelling check.

WordStar displays the number of words checked.

Press Esc to return to the document.
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UsING THE THESAURUS

As you write or edit, the thesaurus can help you find the exact word you want.
Practice using the thesaurus in the file SPELL.DOC.
7 Move the cursor to a word for which you want to see synonyms.

2 Choose Utilities=>Thesaurus (Alt+U,T). The synonyms are displayed.

e ——— e []]ESL[1][5 e———— |

Word: "school"

Noun [ESEEANTS, academy, college, lyceum, seminary, university:
band, clique, cabal, camp, circle, clan, coterie, coven, cult,
faction, family, gang, group, mob, ring, sect, tribe.
Uerb educate, train, coach, communicate, condition, conuey, cultivate,
develop, discipline, drill, edify, enlighten, exercise, explain,
1 groonm, imbue, impart, implant, improuve, inculcate, indoctrinate,

To insert a word in your text, highlight it and select OK.

I Type Neu Word K Define Highlighted Word
L Cross-reference P Return to Previous Word Cancel
e e

glover and wool dealer with a shop in Stratford.

Shakespeare entered grammar Echool in 1571 at the age of seven.
Elizabethan education was based on learning by rote, and he had
an excellent aural memory. His education in Latin left an
unmistakable impression on his vocabulary. In the upper school,
Insert P1 L9 U1.83" C38 H2.98"

3 Select one of the synonyms. Press F10 or choose OK.
The synonym replaces the original text.

Try some of the other thesaurus functions.

1 Type separate and leave the cursor on that word.

2 Choose Utilities=>Thesaurus (Alt+U,T).
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Note that the synonyms are listed by parts of speech.

Press the Down Arrow several times to move through the list. Press the Up
Arrow to move back to the original word in the list.

Press K to see a definition for “separate.”
Press Esc to return to the synonyms.

Move the cursor to one of the synonyms and press K to see the definition of
the synonym.

Press Esc twice to return to the document.

Close and abandon the file.

6-13
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EpIiTinG 4
NEWSLETTER

In this chapter you'll learn about

O Newspaper-style Columns

4 Previewing Columns

Newspaper-style columns allow you to create newsletters. You can set up a

document in newspaper-style columns so that text wraps continuously from the
end of one column to the beginning of the next.

CREAT ING NEWSPAPER-STYLE COLUMNS

To set up a document with newspaper-style columns, follow the steps below.
7 Open the sample file SHAKE.DOC.
2 Move the cursor to the beginning of the first paragraph.

3 Choose Layout=>Columns (Alt+L,0) to see the Column Layout dialog box.
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4 Type the number of columns you want, for example, 2 or 3.
Use the default .25" for Space Between Columns and the default 6.5" for the
Right Page margin. At the bottom of the dialog box, WordStar calculates the
width of the column for you.

5 Press F10 or choose OK to close the dialog box.

The column commands are inserted into the document.

6 Choose Utilities=>Reformat=>Rest of Document (Alt+U,R,R) to reformat the
text to the new margins.

TIP You can also use the classic command *QU to reformat text.

Return to the beginning of your document—it should look like this:

WordStar - C:\WS\SHAKE.DOC
File Edit \Vieu Insert Style Layo ili

Body text ourier 18 PC

William Shakespeare is the most
= He was born in 1564 in

chool in 1571 at the age of
Elizabethan education
Euas based on learning by rote,
Insert P1 L1 UB.58" C1

The columns don’t appear side by side on the screen. To see how the text will
look when it’s printed, use Preview.

1 Choose View=>Preview (Alt+V,P) to see the newspaper-style columns side
by side.
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USING PARAGRAPH STYLES IN COLUMNS

Use PgDn to move to page 2.
The columns appear throughout the document.

Press Esc to exit Preview.

USING PARAGRAPH STYLES IN COLUMNS

Paragraph styles are useful for formatting columns. However, you need to
remember to inherit (leave blank) the right margin setting. Some predefined
styles, such as Body Text, have a right margin of 6.5 inches. This setting would
not be correct for newspaper-style columns. However, if you inherit the right
margin created when you set up the columns, the correct column margins are
maintained.

For more information about inheriting paragraph style settings, see the chapter
on “Creating and Editing Paragraph Styles.”

In the steps below, you'll create and use a paragraph style with newspaper-style
columns. The style will contain a paragraph indent.

1

In the file SHAKE.DOC, move the cursor to the beginning of the first
paragraph in newspaper-style columns. Make sure the cursor is positioned
after the column commands.

Choose Style=>Define Paragraph Style (Alt+S,D) to define a paragraph style.
Choose Body Text.

Type Newspaper Indent for the name of the new style.

Press Alt+1 to move the cursor to the First Line Indent box.

Type .2 for the first line indent.

Press the Tab key to move to the Right Margin box.

Press the Spacebar or AY to clear the Right Margin box.
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Your screen should look like this:

Define Paragraph Style

Style: Left Margin: BENCIN
ist Line Indent: J¥aS
Font: Right Margin: . Cancel
Leading: CLine Height) Line Spacing:
ke SHl. 50" 1.00"1.58"-2.88"-2.50"-3.00"-3.50"'-4.80" - 4.58"-5.88"-5
On Off Inherit AlignmMent: ¢ Flush Left
Bold o . [ o Centered
Italic o [} o Flush Right
Underline o . o o Justified
Strikeout o . o o Inherited
Doublestrike o . [
Superscript o . 0 Colors/Shading: |GGG
Subscript o * (]
Word Urap ¢ [ o [-1 Update Style Library

9 Press F10 or choose OK to save the style.
The style is saved to the document but is not saved to the library.

In the following steps, you'll insert the new paragraph style. The right margin is
inherited and the new first line indent takes effect.

1 Choose Style=>Select Paragraph Style (Alt+S,S) to select a style.

2 Select the new style, Newspaper Indent.
The paragraph is indented and inherits the right margin for newspaper-style
columns. To indent subsequent paragraphs, you need to reformat the rest of

the document with AQU.

3 Close and abandon the file.




CHAPTER 8

SING MACROS TO
EDIT

In this chapter you'll learn about

{18

Recording a Macro

(]

Playing a Macro
L Editing a Macro
U Creating a Macro

Macros help you automate word processing tasks. They can be used to type fre-
quently used text or to execute a sequence of commands. You create a macro
by recording and saving your keystrokes. When you play the macro, the
keystrokes that you recorded are carried out. You can edit the macros to cor-
rect any errors or customize them.

REcorpING A MACRO

When you record a macro, WordStar captures and saves the keystrokes in a
macro file. When you press the hot key you assign to the macro, the macro
executes the keystrokes that you saved.
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Follow the steps below to record a macro that saves the current file, opens a
window on another file, and sizes the window. You'll call the macro
“Window.”

1 Choose File=>Open Document (F,D) and name the file MACRO.DOC.

2 Type the sample text below:

WordStar stores each macro as a file, with the name you
gave it while recording or editing and the .WSM extension.

3 Choose Utilities=>Macros=>Record (Alt+U,M,R) to record a macro.

The Record Macro dialog box appears.

Record Macro

Macro Nane: [N Hot. Key: I
Description: [ ERETT

To stop recording, press Alt+=

Macro: Hot Keys:

IlIIIIIIIIIIlIlIIIIllIIIIlllllIIllIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII‘

4 In the Macro Name box, type window.

Note: When you name a macro, use a name that will help you identify it.
You can use up to eight characters. WordStar assigns the .WSM extension
to the filename.

5 Press the Tab key.
The cursor moves to the Hot Key box. Now you’ll assign the single key or
combination of keys for running the macro. For more information about hot
key assignments, see the Reference manual.

6 Press the Down Arrow to choose a hot key from the list of available hot keys.

7 In the Hot Key list, move the cursor to Alt+W and press Enter.
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RECORDING A MACRO

Alt+W appears in the Hot Key box and the cursor moves to the Description
box.

In the Description box, type a description of the macro. Type Save
file-Open window-Size window.

You can use as many as 48 characters, including spaces, for a macro
description.

Now that you’ve named and described the macro, you’re ready to record
the keystrokes.

Press F10 or choose OK to begin recording keystrokes.

(Ignore the End Recording message at the top of the screen.)

Now you'll record the following sequence of keystrokes for the macro:

1

2

Press Alt+F,S to save the file MACRO.DOC.

Press Alt+F,W to open a window on a second file.

The Open Document dialog box appears.

Press Alt+Hyphen (hold down the Alt key while you press the hyphen key)
to insert a pause for input command into the macro. When you play back
the macro later, the macro will pause while you enter a filename.

Type REVIEW.DOC for the second filename.

Press Alt+hyphen to end the pause for input.

The macro resumes recording.

Press F10 or choose OK to open REVIEW.DOC.

Press Alt+V,W to size the window.

In the Change Window Size dialog box, press F to make each window use
the full screen. Press F10 or choose OK to close the dialog box.

Each window now uses the full screen.
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9  Press Alt+Equal (hold down the Alt key while you press the Equal key) to
stop recording.

10 Close and abandon REVIEW.DOC. Then close and abandon MACRO.DOC.

You now have a macro that saves a file, opens a second window, and sizes the
window to fill the entire screen.

P1avING A MACRO

When you play a macro, the commands recorded in the macro are carried out.
You can play a macro by using a menu command or the assigned hot key. In
the following section, you'll play the WINDOW macro by using the hot key

you assigned.
17 Open the MACRO.DOC file.

2 Press Alt+W to play the WINDOW macro. When the Open Document
dialog box appears, the macro pauses for input.

3 Type a filename for the second window and press Alt+Hyphen to end the
pause for input. The second window is opened and sized.

4  Close and abandon both files.

EpITING A MACRO

After you record a macro, you may want to change it. WordStar has a macro
language that you can use to edit a macro.

Follow these steps to edit a macro:
7 Atthe Opening screen, choose Ultilities=Macros=>Edit/Create (U,M,E).

The Edit/Create Macro dialog box appears.
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2 In the Macro Name box, type window.
3 Press F10 or choose OK to edit the macro.
The WINDOW macro (WINDOW.WSM) is opened.
In every macro file, you'll see the command “Sub MAIN”" which is a subroutine.
A subroutine is a collection of statements that are invoked by the Sub com-

mand. Each macro must contain the Sub MAIN subroutine.

Subroutines usually contain key functions. A key function tells the macro
which keys to play back. The format for a key function is:

Key (“key stroke string”)
In the Window macro, you'll see these key functions near the end of the file.

KEY (”“{F10}{Alt+V}iw")
KEY (“f")

The first key function above displays the Change Window Size dialog box. The
second key function changes the window size to full screen.

In the following steps, you’ll put a comment at the beginning of the
WINDOW.WSM file to provide descriptive information about the macro. A
comment is a statement for you to read but is not a command for the macro to
execute.
1 Atthe beginning of line 1, type this text:

rem Saves current file, opens and sizes second window.

2  Press Enter.

In the following steps, you’ll change a key function so that the window takes up
only five lines instead of the full screen.
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The key function looks like this:

KEY (“f")
Move the cursor to the “f” in the key function.
Delete the “f” and type L5.
Choose File=>Save and Close (Alt+F,L) to save the macro.

Open a file and the WINDOW macro to see the changes you just made. (If
you need help, see “Playing a Macro” in this chapter.)

If WordStar finds errors, it returns you to the macro file to correct them.

CREATING A MACRO WITH THE MACRO LANGUAGE

In this chapter, you’ve created a macro by recording your keystrokes. Now
you'll create a macro using the macro language.

In the following steps, you’ll create a macro that runs a spelling check, saves
your document, and then runs Preview.

1

2

At the Opening screen, choose Utilities=Macros=>Edit/Create (U,M,E).

Assign a macro name, for example, SPELL. WordStar gives the file a .WSM
extension.

Assign a hot key such as Alt+3 and type a description.
Press F10 or choose OK to open the macro.

WordStar opens the new macro.

On line 1, type this text:

rem Runs spelling check, saves file, runs Preview.

Press Enter.
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7 Type Sub MAIN and press Enter. This marks the beginning of the main

subroutine.

On the next two lines, type the sample statements shown below. (You can
type these statements in all lowercase; the case used below is for readability
only.)
Note: “AutoRestore(ON)” is an example of a statement. When there is
more than one statement on a line, the statements must be separated by
colons. When you type statements, separate them with a space, a colon,
and another space.

AutoRestore (ON) : SetHelpLevel(4) : Insert (ON)

CmdTags (OFF) : HideDots(ON) : ColMode (OFF)

ColReplace (OFF)
Press Enter.
The statements establish these settings:
AutoRestore(ON) Restores original settings after the macro plays.

SetHelpLevel(4) Sets the help level at 4.

Insert(ON) Allows characters to be inserted into existing text instead of
overwriting text.

CmdTags(OFF) Turns off the display of command tags.
HideDots(ON) Turns off the display of dot commands.

ColMode(OFF) Turns column mode off. This is the default for marking
blocks.

ColReplace(OFF) Turns off column replace. This is the default for moving
and copying blocks.
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In the following steps, you'll type two key functions and some exception
conditions:

The first key function that you'll type is:
Key (" {Alt+U}S")

1 Type Key(” to begin the Key function. Every Key function begins with
(” and ends with ”).

2 Type {Alt+U}S to move the cursor to the beginning of the file and start the
spelling check.

3 Type”) to end the function. Press Enter to move to the next line. Press the
Tab key to indent the line.

4 Type IfException and press Enter.
When a spelling check is complete, WordStar displays a message giving the
word count. This is an exception condition. When a macro encounters an
exception condition, you can have the macro pause while you provide
required input or you can tell the macro to provide the input. To have the
macro provide input, you add an IfException clause to your macro
statement. In the following steps, you tell the macro to issue an Escape
when the word count message is displayed.

5 On the next line under “IfException” type ACK: Key(”{Esc}”) and press Enter.

The ACK clause issues an Escape key command when the spelling check
message appears.

6 To end the IfException clause type End IfException and press Enter.
7 Type Key(”{Alt+F}S”) and press Enter. This key function saves the file.

8 Type Key(”{Alt+V}P”) and press Enter. This key function runs Preview.
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9 Type End Sub to end the subroutine and press Enter.
When your macro is finished, it will look like this:

rem Runs spelling check, saves file, runs Preview
Sub MAIN
AutoRestore (ON) : SetHelpLevel(4) : Insert (ON)
CmdTags (OFF)
HideDots (ON) : ColMode(OFF) : ColReplace (OFF)
Key (“{Alt+U}S")
IfException
ACK: Key (“{Esc}”)
End IfException
Key (“{Alt+F}S")
Key (“{Alt+V}P")
End Sub

10 Save the macro and then play it in a document.



CHAPTER 9

USING WORDSTAR
WITH OTHER FILE
FORMATS

In this chapter you'll learn about
O Creating Fax Files
4 Converting Graphics Files to .PIX Format

The Fax feature allows you to create fax files from WordStar documents and to
send the files without printing them first or using a fax machine. First you cre-
ate a .PCX graphics file for each page you want to fax. Then, you can use a fax
board and fax software to transmit the files. If your fax board doesn’t support
.PCX files, you need to convert the files. Most fax software provides a conver-
sion utility.

WordStar can insert graphics into your document. If the graphics file is not in
.PIX format, WordStar converts the file for you. You can choose certain set-
tings, such as the height and width of the graphic, when you convert the file.
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C REATING FAX FILES

Although you can use any printer description file (PDF) to format a document
for fax transmission, you get the best appearing fonts when you format the docu-
ment for a laser printer. If you don’t have a laser printer, you can use the
FAX.PDF file that comes with WordStar.

To complete the following steps, you need a document to fax. Assign a laser
printer (PDF) file or FAX.PDF to the document. For more information on using
PDFs, see the “Printing” chapter.

CREATING FAX FILES AT THE OPENING SCREEN

In the following steps, you’ll create a fax file from the Opening screen. (You
can also create fax files from the Editing screen and from inside Preview.)

1

2

At the Opening screen, choose File=>Fax (F,F).
In the Fax dialog box, type the name of the WordStar document to fax.

Press Alt+N (or the Tab key) to move the cursor to the Name of Fax File.
Type five characters that describe your file, for example, chart.

WordStar adds three numbers to indicate the page sequence. WordStar also
adds the extension .PCX to the filename. For example, if you type chart for
the filename and choose to create fax files for pages 3, 5, and 6, the
filenames will be CHART001.PCX, CHART002.PCX, and CHART003.PCX.
WordStar creates a file for each page.

Press the Tab key to move to the Fax Page Numbers option and select the
pages to fax. To fax all pages, press Alt+A. To print selected pages, press
Alt+S, and type the page numbers. You can select multiple ranges and
discontinuous pages.

Note: The page numbers refer to the physical position of the page in the
document. Any page numbering commands you may have entered will be
ignored.

Move the cursor to the Resolution options and select the resolution for your
fax.
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R Fax A

Fax File Location: C:\WS\FAX % Cancel
Name of Fax File: EER. Pcx Resolution: E View §
o Lou
Fax Page Numbers: ¢ High
¢ All o Special 300 dpi
o Selected Pages: [ o 98-rin Dot Matrix
o 24-pin Dot Matrix

—

CREATING FAX FILES

The resolution setting should match the setting in your fax board software.
Resolution can be set to Low, High, or Special 300 dots per inch (dpi). Low
resolution is 200 x 100 dpi. High resolution, the default, is 200 x 200 dpi.
The 300 dpi option is provided for fax drivers that use this resolution. (The
9-Pin Dot Matrix and 24-Pin Dot Matrix options are not used for creating fax
files.)

Choose the View button to view the file and verify the pages to fax.

Page one of your document appears. All the options on the Preview menus
are available. You can preview any part of the file.

To determine the resolution of the fax printout, check the Preview display at
4x zoom (View menu).

Press Esc to return to the Fax dialog box.

The Fax dialog box should look like this:

File to Fax: C:\WS\CHART.DOC

Press F10 or choose OK to create fax files.

As the fax file is being created for each page, a view of the entire page
displays in Preview. The name of the file being created appears at the top of
the Preview screen. When all the required fax files have been created,
WordStar returns you to the Opening screen.

Exit WordStar.
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VIEWING FAX FILES OUTSIDE WORDSTAR

You can view fax files without starting WordStar. The first time you create a fax
file, WordStar makes a FAX directory off the directory containing the
FONTID.CTL file (usually the WS directory). All .PCX files are placed in this
FAX directory. If you want to view files before you fax them, you can use the
program SHOWPCX.

Follow the steps below to view a fax file at the DOS prompt.

1 Be sure you're logged on to the directory containing your WordStar files
(usually WS).

2 Type showpcx fax\filename (you don’t need to type the .PCX extension),
and press Enter to view your fax file.

If you want to review the document, use the direction keys to move around
the page. Use the plus and minus keys on the numeric keypad to change
magnification.

3 Press Esc to return to the DOS prompt.
You can now send your fax files using your fax software.

The .PCX files created by WordStar are large files, averaging 100K each. To cre-
ate additional disk space, you can delete fax files that you no longer need.
When you create fax files, screen fonts (.CRT files) are also created. To delete
.CRT files, you can run the DELCRT program. For more information on
DELCRT, see the Reference manual.

CONVERTING GRAPHICS FILES TO .PIX FORMAT

WordStar can add graphics files to your documents. If your file is not in .PIX
format, WordStar offers several options for converting the file.

For the following steps you'll need a graphics file that’s in a format other than
.PIX. You can use the sample graphics file WSILOGO.PCX.
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If you haven't already installed Inset or Graphics Conversion, install them using
the Add or Remove a Feature option on the WINSTALL menu. Follow the setup
instructions in the “Inset” section of Companion Programs.
1 Start WordStar and open the file PLAYBILL.DOC or MAILING.DOC.
2 Move the cursor to where you want the graphic to appear.
3 Choose Insert=>Graphic (Alt+1,G) to insert a graphic.
The Insert Graphic dialog box appears.
4  Type \ws\inset\wsilogo.pcx. Press F10 or choose OK.
The Convert Graphic dialog box appears. The name of the graphics file

appears in the Original Filename box. The converted filename is the same
as the original filename except for the .PIX extension.

Conuert Graphic

The graphic you have chosen is not in WordStar format.
WordStar will convert the graphic to .PIX format.

Original Filename: C:\WS\INSET\WSILOGO.PCX

Converted Filename: [SENINNGRIOYENINI§H0IE{0 A0S

Conuversion Options:
¢ Use Settings in File
o Use Settings on Options Screen

5 Press the Tab key to accept the current name, or type a new name for the
converted file and press the Tab key.

Before you convert the file you should review the conversion settings and
change them as needed. Follow these steps to view/change the conversion

options:

1 In the Convert Graphic dialog box, press the Down Arrow or ~X to select
Use Settings on Options Screen.

2 Press O to choose Option.
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The Convert Graphic Options dialog box displays.

Convert Graphic Options

Height: BB Colors:
Width: o 2
Aspect: width7height o 4 Cancel
Rotation: degrees ¢ 16
[-1 Reverse B/W
[-1 Smoothness Process Type:
[-1 Ignore Background ¢ Snap
o Halftone
Resolution: o Dither
Horizontal: (4 dpi o Diffuse
Uertical: [ dpi
Color Processing:
Screen Frequency: (4 1pi ¢ Allouw Color
Contrast: (4 o Force Gray
Brightness: [ o Force B/W

Notice the Height, Width, and Aspect boxes in the Convert Graphic Options
dialog box. These options are related. Specifying any two of the three
values determines the third. Aspect (ratio) is defined as the width of a
graphic divided by its height. Aspect ratios are indicated as decimal values.

Type values in the Height and Width boxes and the Aspect ratio will
automatically be calculated. You won't see the calculation on the screen.
Or, you can accept all values by pressing the Tab key.

For most conversions, you can use the default settings for the remaining
options in the Convert Graphic Options dialog box.

Press F10 or choose OK to save your selections and return to the Convert
Graphic dialog box.

In the Convert Graphic dialog box, press F10 or choose OK to convert the
graphic and insert it into the document.

The graphic is converted to a .PIX file and inserted into your document. The
settings you selected in the Convert Graphic Options dialog box are saved
in the TOPIX.SET file. The next time you use this dialog box, the settings
will reflect your changes.

You can use Preview to see how the graphic will look on the printed page.

Close and abandon the file.



CHAPTER 10

PRINTING

In this chapter you'll learn about

0 Setting Up Your Printer

0 Changing Printers and Fonts

1 Printing a Standard Business Envelope

1 Using Laser Printers and Other Page Printers

This chapter presents some basic information about printing in WordStar.

SETTING UP YOUR PRINTER

There are two types of ports—parallel and serial—for connecting your printer to
your computer. With a parallel port connection, the printer receives all eight
bits of character codes at the same instant over eight wires. With a serial port,
bits are sent one at a time over fewer wires. Printers are connected by cables to
the ports located at the back of the computer. When you install a printer in
WordStar, you need to specify which port your printer is connected to. LPT
ports are parallel ports and COM ports are serial ports. The default port in
WordStar is LPT1.
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If you have a serial connection, make sure your AUTOEXEC.BAT file contains
the correct mode statement. The mode statement should look like this:

mode com1:9600,n,8,1,p

If necessary, replace “com1” with the correct port number for your system, and
replace ”79600” with the baud rate your printer is set for. For more information,
see the manual that came with your printer.

C HANGING PRINTERS AND FONTS

When you install a printer, you specify the name of your printer, the fonts to
use, and the computer port. WordStar creates a printer description file (PDF)
with this information. You assign a name to the PDF; for example, if you have
a laser printer, you might call it LASER. WordStar adds the extension .PDF, so
the printer description filename would be LASER.PDF. When you create a
document, the PDF for your default printer is assigned to that document. For
more information about installing printers, see the Installing and Customizing

booklet.

CHANGING PRINTERS

If you installed more than one printer to work with WordStar, and you want to
print with a different printer, you can change the printer assigned to a document.

To use a different printer than the one assigned to your document, follow
these steps:

7 Open afile.

2 Choose File=>Change Printer (Alt+F,H).
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Change Printer

Printer for This Document: [TEINEN'

Printers:
ASC256 | ASCII | DRAFT | HPLASER | WS4 |

In the Change Printer dialog box, WordStar displays the name of the printer
assigned to this document and a list of the installed printers.

3 Select a printer from the list.
4 Press F10 or choose OK to close the dialog box.
CHANGING FONTS

You can display a list of fonts that are available for the current printer. You can
then change fonts by following these steps:

1 Choose Style=>Font (Alt+S,F).

I 2 Courier- 18- PC 15 i

Fonts: Printer: HPLASER
Courier 18 PC Courier 12 PC | Line Pr 17 PC | Times PC ...
Univers PC ...

You see the name of the current printer as well as the font now in effect.
The other available fonts are listed.

2 Select one of the fonts and close the dialog box.
The font tag appears in the text area. Text will reformat in the paragraph

containing the font tag. Subsequent paragraphs affected by the new font
need to be reformatted.
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3 Choose Utilities=>Reformat=>Rest of Document (Alt+U,R,R). The rest of
the paragraphs are reformatted. The font tag is in effect until another font

tag is inserted.
TIP  You can also use the classic command "QU to reformat text.
Follow these steps to see how the document will look when printed:

1 Choose View=>Preview (Alt+V,P) to view the page with the new fonts.

2 Press Esc to exit Preview.
3 Close and abandon the file.

For more information about fonts, see “Using Fonts With WordStar” in this
chapter.

P RINTING A STANDARD BUSINESS ENVELOPE

10-4

You can print envelopes by setting a shorter page length and special margins.
The format in the example below is suitable for a standard 9.5 x 4-inch business
envelope, printed 10 characters per inch. It is designed for printers such as dot
matrix and daisy wheel printers that are nonlaser and nonpage printers.

To create a standard format for envelopes, follow these steps:

1 Open a new file.

2 Choose Layout=>Page (Alt+L,P) to see the Page Layout dialog box.

3 Specify the following settings for the envelopes:

Odd page offset 4.00"
Even page offset 4.00"
Top margin 2.00"
Bottom margin 0.00"
Page length 4.00"
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4 Choose Layout=>Page Numbering=>Print Page Numbers (Alt+L,N,P) to omit

5

page numbers from the envelope. Press F10 or choose OK.

Save and name the envelope format file.

If you use different sizes of envelopes, you can create individual formats using
different margin and tab settings. You can store each format in a separate file.
Then, when you want to print an envelope, you insert the appropriate format
file following the last page of your letter.

Follow these steps to insert an envelope format file so you can print the
envelope immediately after you print a letter:

1

2

Open an existing file (letter) or use the sample file MAILING.DOC.

Choose Edit=>Go to Other=>Document End (Alt+E,O,O) to go to the end of
the file.

If your file has headers or footers, complete step 3. If not, move to step 4.
(If you're using MAILING.DOC which has no headers or footers, you can
move to step 4.)

Choose Layout=>Headers/Footers (Alt+L,H). Select the same header or
footer commands that exist in your letter.

You add no text to the new headers and footers and they cancel your
previous headers or footers. You don’t want the headers or footers to print
on the envelope.

With the cursor at the end of the file, choose Insert=>Page Break (Alt+I,P) to
insert a page break. Your envelope format will follow the page break.

Just below the page break, choose Insert=>File (Alt+1,F).

Type the name of the envelope file that you created in the previous section.
Press F10 or choose OK.

The envelope file is inserted at the end of the document.
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7 Beginning in line 1, column 1, immediately below the dot commands for

the envelope, type the name and address for the envelope.

8 Save thefile.

9 When you print the file, select the print option Pause Between Pages so you

can insert an envelope in the printer at the appropriate time.

If you have a laser printer, WordStar provides special envelope files.
HP-ENV.LST is for the HP Laser]et, the LaserJet Plus, and other printers that
feed envelopes from the right side of the printer tray. HP2-ENV.LST is for the
HP Laser]et series Il and Il and other printers that feed envelopes from the cen-
ter of the manual feed tray. For more information on these files, see the
“MailList” section of the Companion Programs manual.

ABOUT LASER PRINTERS AND OTHER PAGE PRINTERS
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Page printers print a page all at once rather than one character or line at a time
as nonpage printers do. Laser printers are page printers. Following are some
terms that may be useful to know if you have a page printer:

PROPORTIONAL AND NONPROPORTIONAL FONTS

A nonproportional font has fixed spacing, that is, every letter takes up the same
amount of space. A proportional font has proportional spacing, that is, some
characters are wider and take up more space than others. Text printed with a
nonproportional font has an inconsistent appearance, with gaps between some
of the letters. Text printed with a proportional font is spaced more consistently
on the page. Some examples of the two types of fonts are shown below.

NONPROPORTIONAL PROPORTIONAL
TIMIMMmImmm mmmmmmmm
131439434 iiiiiii
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TYPE SI1ZES

The size of a font is measured in points, for example, Times Roman 10-point.
There are approximately 72 points in an inch. Font height is measured from the
lowest descender (for example, the bottom of the letter “p”) to the highest
ascender (the top of a capital letter) including a small amount of extra space.

For long sections of text 9-, 10-, and 11-point fonts are the easiest to read.

SERIF AND SANS SERIF

Serifs are the small lines that cross the main strokes of a letter. An example of a
serif typeface is Times Roman; an example of a sans (without) serif typeface is
Helvetica. Note that Helvetica has only the strokes required to define the let-
ter, while Times-Roman has extra little lines.

Most typographers feel that serif type is easier to read in long paragraphs of text
because there are more lines defining each letter. Sans serif type is used for
headings or short paragraphs. Because sans serif type looks more modern, it is
often used for technical documents.

TYPE FAMILIES AND TYPEFACES

A type family, font family, or typeface is a type design, like Times Roman or
Helvetica. It's best to limit yourself to two or three type families per document.
Be careful when you mix type families on a page. Some typefaces look better
together than others. Generally speaking, a serif and sans serif typeface or two
sans serif typefaces look better on a page than two serif typefaces.

Each type family contains several variations within it, for example, roman
(upright, regular weight), bold, and italic. Bold and italic are difficult to read
in long sections of text, but are good for adding emphasis to particular words
or phrases.

SYMBOL SET

A symbol set is a set of characters that a font contains but that may not appear
on your keyboard. The actual characters available depend on your computer
and your printer. A character must be included in the symbol set of the font
you’re using or it won’t print. Symbol sets may contain international characters
or line and box drawing characters.
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ORIENTATION

Orientation refers to the position of text on the page. Portrait-mode orientation
prints text across the width of the page; landscape-mode orientation prints text
across the length of the page. Landscape orientation is available only with
page printers.

USING FONTS WITH WORDSTAR

portrait landscape

Many fonts are available for page printers. Fonts fall into three categories:
internal, cartridge, and soft.

= Internal fonts Every page printer has at least one internal font. Information
about internal fonts is stored permanently in the printer’s memory. Most of
these fonts are nonproportional, portrait-mode fonts. They are always
available to the printer.

Unless you replace the internal fonts with other choices (when you install
your printer), these fonts are available when you press AP= at the WordStar
editing screen.

= Cartridge fonts You can purchase cartridges that contain extra fonts. To
use a cartridge font, you must insert the appropriate cartridge into the printer.

To use a cartridge font with WordStar, you specify the fonts on that cartridge
when you install WordStar. If you purchase the cartridge later, you use the
PRCHANGE option in WINSTALL to install the cartridge. If the cartridge
fonts are HP Laserjet scalable fonts, use the LSRFONTS option.
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= Soft fonts Soft fonts are contained on floppy disks. To use these fonts, you
must download them, or send the font information from the disk to the
printer.

You include soft font choices in your WordStar printer description file (PDF).
You add soft fonts to a PDF using the PRCHANGE option. Some soft fonts
are supplied with WordStar. You can install these fonts when you install
your printer. For soft fonts that aren’t listed in PRCHANGE, use the
LSRFONTS option to add the fonts to the customized database. Then use
PRCHANGE to add the fonts to a PDF. The fonts must be downloaded to
the printer.

For more information on downloading fonts, see the Installing and
Customizing booklet.

BITMAPPED AND SCALABLE FONTS

All fonts are either bitmapped or scalable.

= Bitmapped fonts Bitmapped fonts hold the characteristics for the size of
each letter in an individual bitmap, or blueprint, which indicates to the
printer where to place every dot of ink. Because printers store bitmapped
fonts in memory, they are ready to use quickly and require a minimum of
software instructions.

= Scalable fonts Scalable fonts are sets of instructions that tell a utility, known
as a font generator, how to create a specific bitmapped font. Because one
scalable font can generate a variety of point sizes, type widths, or even italic,
a scalable font is an economical option for someone who needs a large
selection of fonts.




CHAPTER 11

USING MAILLIST
TO PRINT FORM
LETTERS

In this chapter you’ll learn about

O

Creating a Mailing List

(]

Editing a Mailing List

O

Creating a Form Letter

O

Printing Form Letters

WordStar has a feature called MailList that lets you store names, addresses, and
other information in a data file or mailing list. You can use merge printing com-
mands to insert information from the mailing list into a form letter. Also, you
can print the mailing list onto labels and envelopes. For more information on
the variety of tasks that you can complete with MailList, see the Companion
Programs manual.
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CREATING A MAILING LIST

11-2

To create a mailing list in MailList, follow these steps:

1

At the Opening screen, choose Additional=>MailList (A,M).
The MailList Menu appears.

Press C to choose a data file. (A mailing list is kept in a file called a
data file.)

Type customer.dta and press Enter to create a data file.

Press A to add records to the data file. A record is the information about
one person on the mailing list.

The data entry form appears on the screen. Each area for entering
information on the form is called a field. The cursor is at the Record
Number field.

Type 1 and then press Enter. You’ve assigned the number 1 to the first
record.

The cursor moves to the Date field.
Type 102592 and press Enter.
The date appears as 10/25/92.

Fill in the rest of the form so that it looks like the following screen.
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“Copy from previous record

“Urite/save record in file

Record Number:
Me./Ms.:
Init., Last:
Title:

First,

Company:

Address Line 1:
Address Line 2:
City, State, Zip:
Country:

Phone-1:

Phone-2:

User Fields-

Type data and press <.

00081 Albert G. Alvarez

Jr./7M.D.:

G. Alvarez
English Teacher

Urite School
2338 Lark Ave.

Buena Uista CA_ 95912
181-555-7676

Remarks-—

Date:

18/25792
mM/dd/yy

If you don’t need to fill in a field, press Enter to skip to the next field. If you
make a typing error, you can erase characters with the Backspace key or the
Del key. You can move the cursor around the form using the commands

listed below:

TO MOVE

PRESS

Left one character
Right one character
To the previous field
To the next field

To the top (first) field
To the last field

AS lor ¢

D or =
AN O N &—
AR oA =3
AT or Home

AL or End

8 Check to make sure you typed everything correctly in the form.

9  Press AW to save this information in the data file.

710 Press Enter to save the record.
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Now you’ll add two more records to the data file.

1 For each record, repeat steps 4-10, substituting the information shown
below:

ORM: C: WUSLIST UIEW AND EDIT RECORDS C: CUSTOMER. DTA

“Previous/"Next record “Write/save modified record F1  Help

“Erase record “Create/change record filter Escape

Type any changes and press <.

Record Number:
Mr. /Ms. @
Init., Last:
Title:

First,

Company:

Address Line 1:
Address Line 2:
City, State, Zip:
Country:

Phone-1:

000082 Mary E. Bouen
Ms.

Mary E.
Principal

Bouen
Doguood School

1 Schoolhouse Road
Lynuille
181-555-7497

Remarks—

OH_

Date:

Jr./M.D.:

47308

18/25/92
mMm/dd/yy

ORM: C: WSLIST ADD NEW RECORDS C: CUSTOMER. DTA
“Copy from previous record “Write/save record in file F1  Help
Escape

Record Number:
Me. 7Ms. @
Init., Last:
Title:

First,

Company:
Address Line 1:
Address Line 2:

City, State, Zip:
Country:
Phone-1:
Phone-2:
User Fields-

11-4

Type data and press <.

080003 Lucy Hannis

Ms.

Lucy ___ Hannis
English Teacher

Oakvale High School
7?78 Burton St.

Oakvale
513-555-8380

Remarks-—

KY_

Date: 18/25/92

Jr./M.D.:

32701

mm/dd/yy
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EDITING A MAILING LIST

When you finish typing and saving all three records, press Esc.

The MailList menu appears.

You now have information about three customers in your mailing list.

EpITiNe A MAILING LIST

Once you've added records to a mailing list, you can look at them and make
changes at any time. Follow these steps to look through your records and make
a correction.

1

10

At the MailList menu, press V to view and edit records.
The first record appears on your screen.

Press AN to see the next record.

Press AP to see the previous record.

Press AP again.

A message says that you're at the beginning of the file.
Press Esc to go to the end of the file.

Correct Ms. Hannis’s name to Ms. Harris. Use the same commands to move
the cursor as you did while adding records.

Press AW to save the updated record.
Press Enter to save the data.
Press Esc.

Press QQ to exit MailList.
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CREATING A FORM LETTER
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You're now ready to write a letter to each customer on the mailing list. You'll
create this letter, called a form letter, with WordStar and use merge printing
commands to insert names and addresses from the mailing list.

Start at the WordStar Opening screen.

)

2

Open a new file.

Choose Insert=>File (Alt+1,F). Select the file MAILLIST.DOT. (Include a path
for the MAILLIST.DOT file. It's in the same directory as your MailList
program files, usually WS\OPTIONS.)

MAILLIST.DOT contains the dot commands you need in a form letter.
Move the cursor to the line beginning with .df.

The .df dot command defines the data file as WSLIST.DTA. (WSLIST.DTA is
the WordStar default file for a main mailing list.) You want to use
CUSTOMER.DTA, the data file you created.

Delete WSLIST.DTA and type \ws\options\customer.dta. (Substitute the
correct directory names. MailList creates the data files in the directory that
contains the MailList program files, usually WS\OPTIONS.)

Notice that the next four lines begin with .rv. The words in these lines are
names that correspond to the fields on the mailing list form. You'll use
these names in the letter where you want to insert data from the mailing
list file.

Move the cursor to the blank line above the line which reads (Type text and
variable names here.) Press Y twice to delete this line and the line that
follows so they don’t appear in the letter.

Type the following letter.



CREATING A FORM LETTER

Theatre in the Park
50 Main St.
Franklin, CA 93701

November 15, 1992

&full-name&
&company &

&addrlé&

&city&, &state& &zip&

Dear &Mr-Ms& &lasté:

It’s time to renew your subscription for the Theatre in
the Park summer series. Your seat from last season will
be reserved for you unless you notify us that you wish to
change it.

If you know others at &company& who might be interested in
Theatre in the Park, please ask them to contact us for
more information.

Sincerely,

Sam Hergen

7 When you're finished, check your work.

All the words enclosed in ampersands (&) are called variable names. Use
variable names wherever you want to insert information from the data file.
Variable names must match the corresponding names in the .rv dot
commands.

8 Be sure that all the text is above .pa, the dot command that tells WordStar to
start a new page.

9 Save the file and name it THEATRE.DOC.
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PRINTING FORM LETTERS WITH THE MAILING LIST
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Now you'll print three letters using your mailing list and the original form letter.

1 Be sure your printer is on and ready.

2 At the Opening screen, choose File=>Print (F,P).
Note: In the Print dialog box, Interpret Merge Variables is selected by
default. This means the merge print commands in your document will be
interpreted by WordStar at print time.

3 Select THEATRE.DOC as the file to print. Press F10 or choose OK to start printing.

Three letters are printed, one to each person on the mailing list. The first letter
looks like this:

Now that you've created a mailing list and a form letter and used them together to
print individual letters, you've learned the basics of MailList and merge printing.

Theatre in the Park
50 Main St.
Franklin, CA 93701

November 15, 1992

Albert G. Alvarez

Write School

2330 Lark Ave.

Buena Vista, CA, 95912

Dear Mr. Alvarez:

It’s time to renew your subscription for the Theatre in the Park
summer series. Your seat from last season will be reserved for
you unless you notify us that you wish to change it.

If you know others at Write School who might be interested in
Theatre in the Park, please ask them to contact us for more
information.

Sincerely,

Sam Hergen




CHAPTER 12

MERGE PRINTING
WITH DATA FILES
FROM OTHER
PROGRAMS

In this chapter you'll learn about
1 Printing Envelopes for a Mass Mailing
2 Printing Three-Across Mailing Labels

When you use MailList to create your data file, you can easily print labels,
envelopes, and form letters for mass mailings. If you have a laser printer or
page printer, you can use the .LST files supplied by MailList to print envelopes
or labels. For more information, see the “MailList” section in the Companion
Programs manual.

This chapter contains procedures for printing envelopes and labels using a data
file created by a program other than MailList (the file must contain names and
addresses). You can use a data file created by dBASE, Lotus 1-2-3 (WordStar
supports versions prior to release 3), or any program that creates a comma-
delimited ASCII data file. If you have a dBASE IV file with memo fields, convert
it to a dBASE Il file.
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MERGE PRINTING ENVELOPES FOR A MASS MAILING

You can use information from a mailing list or data file (other than a MailList
file) to print envelopes. Follow the steps in the procedure below to create a
master document, or file, for printing standard envelopes. The settings in this
procedure work for most noniaser or nonpage printers.

1

2

At the Opening screen, open a new document file.

Choose Layout=>Page Numbering (Alt+L,N). In the Page Numbering dialog
box, clear the Print Page Numbers check box. This turns off page
numbering. Press F10 or choose OK.

WordStar inserts the dot command .op to turn page numbering off.

Choose Utilities=>Merge Print Commands=>Data File (Alt+U,P,D) to select
the data file. Type the name of the data file you want to use. Press F10 or
choose OK.

WordStar inserts the dot command .df with the filename.

Choose Utilities=>Merge Print Commands=>Name Variables (Alt+U,P,N).
Type the variable names. For example, type the following variables. When
you finish, press F10 or choose OK.

Mr-Ms,name, addressl, address2,address3

WordStar inserts the .rv command with the variable names. Your file
should look similar to this:

.df client.dta
.rv Mr-Ms,name, addressl,address2, address3

Choose Utilities=>Merge Print Commands=>Ask for Variable (Alt+U,P,A).
The Ask for Variable dialog box appears. For Variable Name, type x. For
Prompt, type Put envelope in printer. Press Enter when ready. Press F10 or
choose OK.



MERGE PRINTING ENVELOPES FOR A MASS MAILING

WordStar inserts this .av command:
.av “Put envelope in printer. Press Enter when ready.”,X

The .av command makes the printer pause before it prints each envelope so
you can insert a new envelope. (In this dot command, disregard the “ x”
variable; it's a trick to make your printer pause and doesn’t affect your file.)

Choose Utilities=>Merge Print Commands=>Clear Screen While Printing
(Alt+U,P,C). In the dialog box that appears, you can use the Message box to
type a message for Wordstar to display after clearing the screen, or you can
leave the Message box blank. Press F10 or choose OK.

The .cs command is used when you print the envelopes. It clears the screen
after you respond to the .av message. If you entered a message in the dialog
box, WordStar displays that message after clearing the screen.

Choose Layout=>Page (Alt+L,P). The Page Layout dialog box appears.
Specify the following settings for a standard 9.5 x 4-inch envelope. When
you finish typing the settings, press F10 or choose OK.

Odd page offset 4.00"
Even page offset 4.00"
Top margin 2.00"
Bottom margin 0.00"
Page length 4.00"

On the line following the last dot command, type these sample variables to
be used when printing the names and addresses from the data file:

&names&

&addressl/o&
&address2/o0&
&address3/o0&

The /o option omits the blank space between lines when there is no data for
one of the address lines.
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9 Choose Insert=>Page Break (Alt+l,P) to insert a .pa command. This
command starts the address for a new envelope.

Now your envelope file should look like this:

.op
.df client.dta

.rv Mr-Ms,name,addressl,address2,address3

.av “Put envelope in printer. Press Enter when ready.”,x
.Ccs

.poo 4.00"

.poe 4.00"

.mt 2.00"

.mb 0.00"

.pl 4.00"

&name&

&addressl/o&

&address2/0&

&address3/o&

.pa

70 Save and print this file. WordStar uses your data file to print envelopes.

PRINTING ENVELOPES
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If you have a laser printer, instead of using the file alone, you can print
envelopes using the HP-ENV.LST or HP2-ENV.LST file. HP-ENV.LST is for the
HP Laserjet, Laser)et Plus, and other printers that feed envelopes from the right
side of the printer tray. HP2-ENV.LST is for the HP Laseret series Il and Il and
other printers that feed envelopes from the center of the manual feed tray. The
HP-ENV.LST and HP2-ENV.LST files are in the directory containing the
WordStar program files (usually WS).

When you choose one of these files to print envelopes, be sure the Interpret
Merge Variables check box is selected and the Use Form Feeds check box is
clear in the Print dialog box.

Using one of these files, you can print an envelope for each record in your data
file. When printing pauses, read the message, insert an envelope, and press Enter
to continue. After you press Enter, the .cs command in the file clears the screen.



MERGE PRINTING THREE-ACROSS MAILING LABELS

MERGE PRINTING THREE-ACROSS MAILING LABELS

In the procedure below, you'll set up a format for merge printing names and
addresses from a data file (other than a MailList file) onto mailing labels. The
procedure uses a data file with five fields: name, street address, city, state,
and zip code. The commands used in the procedure are appropriate for

3.5 x 15/16-inch, three-across labels printed with 10 characters per inch and 6
lines of text per inch. The procedure will work with most nonlaser or nonpage
printers.

Note: If you're using a data file created with MailList, you don’t need to use
the procedure below to print labels. Instead, use the .LST files that come with
MailList. For more information, see the “MailList” section in the Companion
Programs manual.

1 Atthe Opening screen, open a new file.

2 Choose Layout=>Page (Alt+L,P). In the Page Layout dialog box, specify
these settings (when you finish, press F10 or choose OK):

Odd page offset 2.00"
Even page offset 2.00"

Top margin 0.00"
Bottom margin 0.00"
Page length 1.00"

Note: The page length is set to 1 inch so that each row of labels is
considered to be a page.

3 Choose Layout=>Page Numbering (Alt+L,N). Clear the Print Page Numbers
check box to turn page numbering off. Press F10 or choose OK.

WordStar inserts .op to turn page numbering off.

4 On the line following the last dot command in the file, type .pf off to turn
print-time formatting off and press Enter.

12-5



MERGE PRINTING WITH DATA FILES FROM OTHER PROGRAMS

5 Choose Utilities=>Merge Print Commands=>Set Variable (Alt+U,P,S). In
the Variable box, type L. In the Data box, type L 30 times. Press F10 or
choose OK.

WordStar inserts this dot command:
.sv L = LLLLLLLLLLLLLLLLLLLLLLLLLLLLLL (the command has 30 L’s)

This command sets up a format that aligns the variable data and limits the
length of the data (when printed) to 30 characters. (Additional characters
aren’t printed.)

6 Choose Utilities=>Merge Print Commands=>Data File (Alt+U,P,D) so you
can select the data file. Type the name of the data file, for example, type
label.dta. Press F10 or choose OK.

7 Choose Utilities=>Merge Print Commands=>Name Variables (Alt+U,P,N).
In the Variables box, type name1,address1,city1,state1,zip1. Press F10 or
choose OK.

8 Repeat step 7, but in the Variables box, type
name2,address2,city2,state2,zip2

9 Repeat step 7 again, but in the Variables box, type
name3,address3,city3,state3,zip3

The commands you entered in steps 6-9 appear onscreen as follows:

.df label.dta

.rv namel,addressl,cityl, statel, zipl
.rv name2,address2,city2,state2,zip2
.rv name3,address3,city3,state3, zip3

10 Choose Utilities=>Merge Print Commands=>Set Variable (Alt+U,P,S).
In the first Variable box, type cityline1. In the Data box, type
&cityl&, &statel& &zipl&

In the next Variable box, type cityline2. In the Data box, type
&city2&, &state2& &zip2&

In the next Variable box, type cityline3. In the Data box, type
&city3&, &state3& &zip3&
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11 Press F10 or choose OK.

WordStar inserts these .sv commands:

.sv citylinel=&cityl&, &statel& &zipla

.8V cityline2=&city2&, &state2& &zip2&
.8v cityline3=&city3&, &state3& &zip3&

12 Type the variables for the labels. Type 5 spaces between each variable on
each line. The spaces will position the printer at the left side of the next
label. For example, type this:

&namel/L& &name?2 /L& &name3 /L&
&addressl/L& &address2/L& &address3/L&
&citylinel/L& &cityline2/L& &cityline3/L&

13  Choose Insert=>Page Break (Alt+1,P) to insert a page break before the next
set of three-across labels.

Your file should now look like this:

.poo 2.00"
.poe 2.00"

.mt
.mb
.pl
.op
.pf
.8V
.df
TV
LTV
Bt
.SV
.SV
.SV

0
0
1.00"

off

L = LLLLLLLLLLLLLLLLLLLLLLLLLLLLLL
label.dta

namel, addressl,cityl, statel, zipl
name2,address2, city2, state2, zip2
name3, address3, city3, state3, zip3
citylinel=&cityl&, &statel& &zipl&
cityline2=&city2&, &statel& &zip2&
cityline3=&city3&, &state3& &zip3&

&namel/L& &name?2 /L& &name3 /L&

&addressl/L& &address2/L& &address3 /L&
&citylinel/L& &cityline2/L& &cityline3 /L&

.pa
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AVoIDING BIANK LINES ON LABELS
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Some mailing addresses consist of a city, state, and zip code, but no street
address. For example, in the row of three-across labels below, the middle label
for Roland Tums has no street address—the street address line is blank.

Franz Reichsman Roland Tums Rebecca Fies
125 Healing Street 54321 Dolphin Drive
Marlboro, VT 05301 Tinyhamlet, MO 64423 Santa Fe, NM 85102

The middle label would look better if the city, state, and zip code appeared on
the second line, like this:

Roland Tums
Tinyhamlet, MO 64423

In a letter, you can use the /o option to omit a line that contains no data for a
variable. However, the /o option doesn’t work for three-across mailing labels
because the variable data for all three labels is on the same line. You can solve
this blank line problem by using conditional dot commands that ask WordStar
to check for missing data in a particular variable.

For example, a mailing list record usually consists of a name, street address,
city, state, and zip code. The variable data that is most likely to be missing is
the street address. When Wordstar reads all the variables in a data file for a
row of labels, it checks for missing street addresses. If WordStar finds a missing
street address, it moves the name1 information from the first line to the street
address space on the second line. This leaves the blank line at the top of the
label instead of in the middle. Then the row of labels looks like this:

Franz Reichsman Rebecca Fies
125 Healing Street Roland Tums 54321 Dolphin Drive
Marlboro, VT 05301 Tinyhamlet, MO 64423 Santa Fe, NM 85102

Follow the steps below to insert a conditional command so WordStar will
check each address in your mailing list:



AVOIDING BLANK LINES ON LABELS

Move the cursor to the line above the first line of label text.

Choose Utilities=>Merge Print Commands=>If (Alt+U,P, ) so you can insert
the first conditional command. In the Variable Name box, type
&address1&. Press F10 or choose OK.

WordStar inserts a .if command in the file. The .if command tells WordStar
to check the data contained in the variable that is surrounded by
ampersands.

On the line below the .if command insert a blank line, with the cursor on
the blank line, type .sv address1,&name1& and press Enter.

WordStar inserts a .sv command in the file. The .sv command tells
WordStar to move the name data into the address1 variable (the data is
now the same for both name1 and address1).

On the next line, type .sv name1. This .sv command tells WordStar to
delete the nameT variable and leave the field blank.

On the next line, choose Utilities=>Merge Print Commands=>End If
(Alt+U,P,E) to end the condition.

Repeat steps 25 for the remaining two lines of variables. When you finish,
the file on the screen should look like this:

.1if &addresslé&=

.sv addressl, &namel&
.SV namel

.ei

.1f &address2é&=

.sv address?2, &name2&
.SV name?2

.el

.if &address3&=

.sv address3, &name3&
.SV name3

.ei
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When an address field is blank, WordStar moves the name field information
to the address field and leaves the name field blank. When all three address
variables contain data, WordStar ignores the .if commands.

Note: If two or more variables are missing, use additional .if commands
as needed.

7 Close and save the file.

PRINTING THE LABELS

When you print the label file, it uses the names and addresses contained in the
data file you named in step 6 under “Merge Printing Three-Across Labels.”

When you choose the Print command, and the Print dialog box appears, check
to be sure the Use Form Feeds check box is clear. Do not use form feeds when

you print this file. Also, check that the Interpret Merge Variables check box is
selected.

TIP You might want to create a dummy data file containing three names and
addresses that you can print just before printing your real data file. That way,

you can check the position of the labels in the printer and make the necessary
adjustments.
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CHAPTER 13

CREATING
CONTRACTS

In this chapter you'll learn to
1 Create a library of standard paragraphs for a contract

U Create a master document for a contract

CREATIN G A LIBRARY OF STANDARD PARAGRAPHS

In your business documents, you probably use some standard paragraphs over
and over. Rather than retyping these paragraphs each time, you can create a
library of paragraphs to add to your documents whenever you need them. The
following example shows how to create two standard paragraph files for a lease
agreement. You can substitute names and text as appropriate for your business.

Create the first standard paragraph file:

7 Open a new document and give it a descriptive name, such as
LEASEOP.AGR.
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2 Type this text in the file:
The leased stage props are available for sale from Stage
Props, Inc., if the lessee decides to keep them after the
lease period.

3 Save and close the file.

Now create the second standard paragraph file:

7 Open another document file and name it PROBLEMS.PAR.

2 Type this text in the file:

Because of past problems with late return of props, the
lessee agrees to pay a fee of $10.00 per day per prop
after the agreed date if the props are not returned on
time.

3 Save and close the file.

TIP If you use many standard paragraphs in your work, you may want to
store all the paragraph files in the same directory so they’re easy to find.

CREATING A CONTRACT

Now you'll use the standard paragraphs in the master document that you create
for the contract. The master document will contain variables instead of actual
names. When you print the master document, WordStar asks you what names
you want to use in the document and substitutes that information for the vari-
ables. You can substitute different information in each contract.

In the steps below, you’ll create the master document for a props lease contract.
Start by typing the text of the contract.
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1 Open a new file and name it LEASE.CTR.
2 Type this text in your document:

Lease Agreement

This form shall constitute a formal agreement between
&lessee& (the lessee) and Stage Props, Inc. (the lessor).
Under the terms of this agreement, the lessee agrees to
the following conditions:

&lessee& will receive, on loan, the &prop& for a
theatrical performance.

&lessee& agrees to be responsible for the &prop&’s safe
return to Stage Props, Inc., in good condition, with
allowances for normal wear and tear.

Notice the ampersands at the beginning and end of each occurrence of “lessee”
and “prop.” The ampersands tell WordStar that the word is a variable.

Now you’ll add clauses to the contract by drawing on your library of standard para-
graphs. In the steps below, you'll use conditional commands that tell WordStar to
print the text in PROBLEMS.PAR only when a specific condition is met for the
lessee. You'll have WordStar ask you at print time whether the lessee has caused
problems in the past and to print PROBLEMS.PAR only if you answer “yes.”

1 Atthe end of the LEASE.CTR file, choose Utilities=>Merge Print
Commands=>Ask for Variable (Alt+U,P,A). In the Variable Name box,
type problem. In the Prompt box, type Has this account been a problem?
Press F10 or choose OK.

WordStar inserts a .av command into the file. When you print the file,
WordStar pauses at the .av command and asks Has this account been a
problem? You can answer Y (for yes) or N (for no).

2 Choose Utilities=>Merge Print Commands=>If (Alt+U,P,l). In the Variable

Name box type &problem&. In the Constant box type Y. From the
Operator (Alphabetical) options, select = same as. Press F10 or choose OK.

13-3




CREATING CONTRACTS

13-4

The command .if &problem& =Y inserted into the lease document tells
WordStar to follow the next instruction only if you answered Yes to the
PROBLEM? prompt.

Choose Insert=>File at Print Time (Alt+l,L). In the Filename box, type
PROBLEMS.PAR to insert the problems paragraph. Press F10 or choose OK.

Choose Utilities=>Merge Print Commands=>End If (Alt+U,P,E) to tell
WordStar this is the end of the condition.

WordStar inserts the .ei command into the file.

Finally, you'll tell WordStar to ask you at print time for the name of the lessee
and the type of props being leased.

Move your cursor to line 1, column 1 of the document.

2 Choose Utilities=>Merge Print Commands=>Ask for Variable (Alt+U,P,A). In

the Variable Name box, type lessee. Press F10 or choose OK.

WordStar inserts the command .av lessee. When you print the LEASE.CTR
file, WordStar pauses at this command and asks LESSEE? You type the name
of the lessee.

Choose Utilities=>Merge Print Commands=>Ask for Variable (Alt+U,P,A). In
the Variable Name box, type prop. Press F10 or choose OK.

WordStar inserts the command .av prop. When you print the file, WordStar
pauses at this command and asks PROP? You type the prop being leased.

Your document should now look like this on the screen:




CREATING A CONTRACT

WordStar — C:\US\LEASE.CTR

.av lessee
.av prop

Lease Agreement

IThis form shall constitute a formal agreement betueen &lessee&
(the lessee) and Stage Props, Inc. (the lessor)>. Under the terms
of this agreement, the lessee agrees to the following conditions:

&lessee& will receive, on loan, the &prop& for a theatrical
performance.

&lessee& agrees to be responsible for the &prop&’s safe return to
IStage Props, Inc., in good condition, with allowances for normal
uear and tear.

.av "Has this account been a problem?", problem

.if &problem&= VY

.fi problewms. par

.ei

5 Save and close the file.

Each time you print LEASE.CTR, WordStar asks for the name of the lessee and
the prop being leased. The responses are inserted in place of the &lessee&
and &props& variables. WordStar then asks about problems. If you answer
“yes” to the PROBLEM? prompt, WordStar inserts the problems paragraph
(PROBLEMS.PAR).

Note: When you print this file, be sure that Interpret Merge Variables is

selected in the Print dialog box so WordStar will interpret the merge print
commands at print time.
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CHAPTER 14

CALCULATING
BILLING DATA

In this chapter you’ll learn about

4 Preparing a Billing with Data from dBASE or Lotus
1 Math Capabilities at Print Time

4 Variable Number and Text Formatting

1 Using Conditional Statements and Paragraphs

Preparing a billing involves combining text and data. You need the customer’s
name and address and the amount due. You may also need other specialized
information, such as which regional office the customer should contact if he or
she has any questions. You may also have individualized notes to add to cer-
tain customers’ letters.

WordStar imports information from many database programs. You can add
data about a particular customer without editing the file each time. You can
even have WordStar figure the total due when you print the document.

The steps in this chapter specify using a dBASE IlI file. To follow the instruc-
tions exactly, you'll need a dBASE IlI file containing customers’ names,
addresses, and account data. If you use another program, adapt the instructions
as necessary.
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Note: If you're using a dBASE IV file with memo fields, use dBASE to convert it
to a dBASE Il file. WordStar handles the dBASE Il format more easily.

CREATING A BILLING DOCUMENT

In the following steps, you'll create a form letter to serve as a billing. WordStar
fills in the blanks at print time to create an individual billing for each customer.

1

2

Open a new file and name it BILLING.DOC.

Choose Utilities=>Merge Print Commands=>Data File (Alt+U,P,D). Type the
name of the dBASE file containing your customer information. Include the
complete path to the file. Press F10 or choose OK.

WordStar inserts the dot command .df into the file.

Choose Utilities=>Merge Print Commands=>Name Variables (Alt+U,P,N).
In the Variables box type * to use all of the predefined field names in your
dBASE file as WordStar variables. If you prefer, you can type the variable
names yourself in the same order as they appear in the data file. Press F10
or choose OK.

WordStar inserts the dot command .rv into the file.
Choose Layout=>Page Numbering (Alt+L,N) to display the Page Numbering
dialog box. Clear the Print Page Numbers check box. This turns off page

numbering. Press F10 or choose OK.

WordStar inserts the dot command .op into the file.

TYPING TEXT AND VARIABLES
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In the next steps, you type the text and variables for your billing.

Ampersands (&) around text indicate a variable. Variables are replaced by
actual data at print time. You add the /o option to the customer address fields
to ensure that lines won’t be left blank if some customers don’t have a second
address line.



DETERMINING TOTALS AT PRINT TIME

The &@& date variable is a system variable—the information for that variable is
inserted from your computer’s memory. If the date device in your computer is
set correctly, the correct date replaces this variable when the billing is printed.
The date needs more space than the variable does, so remember to leave
enough room.

7 Type the text for your billing using the following example. If necessary, use
your dBASE variable names instead of those shown in the example.

&Mr-Ms& &full-nameé&

&addrl/o&

&addr2 /o0&

&city&, &state& &zipé& &Q@&

Dear &Mr-Ms& &full-name&:

Per your last order:

&unitsl& &equipl& at &costperl& =

&units2& &equip2& at &costper2&

&units3& &equip3& at &costper3&
Total due

Sincerely,

Mr. Baxter
Baxter and Associates

2 Choose Insert=>Page Break (Alt+,P) to insert a page break.

WordStar inserts the dot command .pa at the end of the text.

DETERMINING TOTALS AT PRINT TIME

Now that you’ve typed the text for your billing, you can use the WordStar math
features to calculate the subtotals and the grand total due. When you print the
file, WordStar makes these calculations for each billing.
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CALCUIATING THE SUBTOTALS
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1

2

Move the cursor to the .op command. The cursor should be in column 1.

Choose Utilities=>Merge Print Commands=>Set Variable to Math Result
(Alt+U,P,V). In the Variable Name box, type total1. In the Mathematical
Expression to be Calculated box, type &units1& * &costper1&. Press F10 or
choose OK.

WordStar inserts the following command:

.ma totall = &unitsl& * &costperl&
The .ma command determines the subtotal.
Choose Utilities=>Merge.Print Commands=>Set Variable to Math Result
(Alt+U,P,V). In the Variable Name box, type total2. In the Mathematical
Expression to be Calculated box, type &units2& * &costper2&. Press F10 or
choose OK.
Choose Ultilities=>Merge Print Commands=>Set Variable to Math Result
(Alt+U,P,V). In the Variable Name box, type total3. In the Mathematical
Expression to be Calculated box, type &units3& * &costper3&. Press F10 or
choose OK.

The .ma commands should look like this:

.ma totall = &unitsl& * &costperl&
.ma total2 = &units2& * &costper2&
.ma total3 = &units3& * &costper3&

The .ma command creates new variables, total1, total2, and total3, which
represent the subtotals for each item ordered.

Move the cursor to the space following the first equal sign ( =) in the text of
the letter.

Press the Spacebar and type &total1&.

Move to the space following the next equal sign (=), press the Spacebar
and type &total2&. Do the same for the third subtotal and type &total3&.



VARIABLE NUMBER FORMATTING

CALCUIATING THE GRAND TOTAL

You can add another .ma command to find the grand total due. WordStar
prints this amount on the line that represents the total due.

1

2

Move the cursor to the .op command.
Choose Utilities=>Merge Print Commands=>Set Variable to Math Result
(Alt+U,P,V). In the Variable Name box, type gtotal. In the Mathematical
Expression box, type &total1& + &total2& + &total3&. Press F10.
The following command appears in your file:
.ma gtotal = &totall& + &total2& + &total3&
Move the cursor to the space following the words “Total due.”
Press the Spacebar and type &gtotal&.

Your text should look like this:

Total due &gtotalé&

VARIABLE NUMBER FORMATTING

Now you'll add some commands to tell WordStar how to print the numbers to
be inserted at print time.

1

2

Move the cursor to the .op command.

Choose Utilities=>Merge Print Commands=>Set Variable (Alt+U,P,S). In the
Variable box, type 1. In the Data box, type ($$$,$$$.99). Press F10 or
choose OK.

The following command appears in your file:

.8v 1=(8$88,5885.99)
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This format tells WordStar to put a dollar sign in front of variables with the
/1 parameter (see step 3 below). If the number is more than 999, a comma
is inserted after the thousands place. If the number is less than 1,000, the
dollar sign is preceded by spaces. If the number is less than zero (for
instance, if the customer has a credit), the number is in parentheses.

3 Add the /1 parameter to each variable in the text that represents a dollar
amount. In your file, these are the three &costper& variables, three &total&
variables, and the &gtotal& variable. For example, the &total1& variable
now looks like this:

&totall/1l&

VARIABLE TEXT FORMATTING

You can control the format of variables that print as text. In the following steps
you'll left-align the &equip& variables you typed in the text.

7 Inyour file, move the cursor to the .op command
2 Choose Utilities=>Merge Print Commands=>Set Variable (Alt+U,P,S). In

the Variable box, type 2. In the Data box, type L 15 times. Press F10 or
choose OK.

The following command appears in your file:
.SV 2=LLLLLLLLLLLLLLL. (Thereare 15 L’s.)

This command tells WordStar to allow 15 spaces for the name of each kind
of equipment purchased. The equipment name aligns at the left margin. If
the equipment name is less than 15 characters long, WordStar adds as many
spaces as necessary to fill the 15-character space.

3 Move the cursor to the &equip& variables in your text. Add the /2
parameter to each one. The &equip1& variable now looks like this:

&equipl/2&

14 -6



USING CONDITIONAL STATEMENTS

USING CONDITIONAL STATEMENTS

Sometimes the information you send to customers varies, depending on where
they live, the amount of their balance, or the date of the billing. In the follow-
ing steps, you'll add a paragraph called a conditional paragraph, that tells cus-
tomers which regional branch of your company to contact, based on the
customer’s address.

Follow these steps to add a conditional paragraph:

1

2

Move the cursor to the blank line above the word “Sincerely.”

Choose Utilities=>Merge Print Commands=>If (Alt+U,P,I). In the Variable
Name box, type &state&. In the Constant box, type CA. From the Operator
(Alphabetical) options, select = same as. Press F10 or choose OK.

The following command appears in your file:

.if &state&= CA

The .if command tells WordStar to use the Western Regional Office
paragraph (see step 3) for customers living in CA (California).

Press Enter after the .if command and type the paragraph containing the
Western Regional Office. For example, type

If you have questions about your billing, contact Gabriel
Grace at our Western Regional Office, 12 San Pablo Road,
San Rafael, CA 94903.

Move the cursor to the next line. Choose Utilities=>Merge Print
Commands=>Else (Alt+U,P,L) to specify the paragraph to print if the
customer lives in a state other than California.

The .el command appears in your file.

Type the paragraph to use for the other customers. For example, type
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If you have questions about your billing, contact Morgan
J. Robinson at our Main Office, 1201 27th Street,
Rockaway, NY 11691.

6  On the next line, choose Utilities=>Merge Print Commands=>End If
(Alt+U,P,E) to end the condition.

Now, every customer in California will receive a billing containing the Western
Regional Office address. Other customers will receive a billing containing the
Main Office address.

C ONDITIONAL PARAGRAPHS BASED ON
THE BAILIANCE DUE

You may want your billing to include an announcement of a special offer or
sale. In the following example, you'll add a paragraph announcing a discount
for customers. The size of the discount will depend on the balance due.

Customers who owe the most receive the biggest discount. You'll add a condi-
tional statement offering a 15% discount to customers whose balance is more
than $300.00.

1 Move the cursor to the line just above “Sincerely,” (create a blank line if
necessary).

2 Choose Utilities=>Merge Print Commands=>If (Alt+U,P,l). In the Variable
Name box, type &gtotal&. In the Constant box, type 300.00. From the
Operator (Numerical) options, select # greater than. Press F10 or choose OK.
This command appears in the file:

.1f &gtotal& #> 300.00

3 Type the paragraph offering the 15% discount. For example, on the next
line type
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Because you’re such a good customer, we're offering a
special 15% discount on all merchandise for the next
month. Take advantage of this special offer to stock up
on all your equipment needs.

Now tell WordStar to offer a 10% discount to the customers whose balance is
less than $300.00 but more than $200.00.

Choose Utilities=>Merge Print Commands=>Else (Alt+U,P,L).

Choose Utilities=>Merge Print Commands=>If (Alt+U,P,1). In the Variable
Name box, type &gtotal&. In the Constant box, type 200.00. From the
Operator (Numerical) options, select # greater than. Press F10 or choose

OK.
Type the paragraph offering the 10% discount.

We’re grateful for your patronage, and we’'re offering you
a special 10% discount on all merchandise for the next
month. Take advantage of this special offer to stock up
on all your eguipment needs.

Now you’ll type a paragraph for customers who don’t earn a discount.

1

Choose Utilities=>Merge Print Commands=>Else (Alt+U,P,L). This tells
WordStar to print the next paragraph if the previous conditions aren’t met.

WordStar inserts the .el command.

On the line following the .el command, type Thank you for shopping with
us. and press Enter.

Now you'll end the conditions by inserting two .ei commands.

1

Choose Utilities=>Merge Print Commands=>End If (Alt+U,P,E).

WordStar inserts the first .ei command.

2 Repeat step 1 to insert another .ei dot command.
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SKIPPING RECORDS IN THE DATA FILE

You don’t want to bill customers who have no balance due. You can avoid
printing a bill for these customers by using the following technique.

1

2

Move the cursor to the .op command.
Choose Utilities=>Merge Print Commands=>If (Alt+U,P,I). In the Variable
Name box, type &gtotal&. In the Constant box, type 0. From the Operator

(Numerical) options, select #> greater than. Press F10 or choose OK.

Choose Edit=>Go to Other=>Document End (Alt+E,O,O) to move the cursor
to the end of the document (after the page break).

Choose Utilities=>Merge Print Commands=>Else (Alt+U,P,L).
WordStar inserts the .el command into the file.

On the next line, choose Utilities=>Merge Print Commands=>Display
Message (Alt+U,P,M). In the Message box, type &full-name& has no
balance due. No billing will be printed. Press F10 or choose OK.

WordsStar inserts a .dm command followed by the message you just typed.

When WordStar finds a customer who has no balance due, it displays this
message onscreen and doesn’t print a billing.

Choose Utilities=>Merge Print Commands=>End If (Alt+U,P,E) to end the
conditional statement.

I NCLUDING DBASE III MEMO FIELDS

The dBASE 11l and dBASE 11l Plus programs have a memo field feature that
allows you to make extensive notes about each record in your data file. If you
want to include the dBASE notes for each customer, follow these steps:
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7 Move the cursor to the place in your billing where you want WordStar to
print the memo field.

In this example, the memo field is called NOTE, so the variable for that field
is &note& (the variable name must always match the field name).

2 Type &note& in your file. The entire memo field will print at the &note&
variable.

Tue BILLING DOCUMENT

Now that you’ve completed the steps in this chapter, your billing document
looks like this:

.df c:\dbase\customers.dbf

I

.ma totall=&unitsl& * &costperl&

.ma total2=&units2& * &costper2&

.ma total3=&units3& * &costper3&

.ma gtotal=&totall& + &total2& + &totall3&
v 1=(8$85,555.99)

.sv 2=LLLLLLLLLLLLLLL

.if &gtotal& #> 0

.op

&Mr-Ms& &full-name&

&addrl/0&

&addr2/0&

&city&, &state& &zipé& &Q&

Dear &Mr-Ms& &full-name&:

Per your last order:
sunitsl& &equipl/2& at &costperl/l& = &totall/lé&
sunits2& &equip2/2& at &costper2/1& = &total2/l&
sunits3& &equip3/2& at &costper3/l& = &total3/l&
Total due &gtotal/l&
.1if &state&=CA
If you have guestions about your billing, contact Gabriel
Grace at our Western Regional Office, 12 San Pablo Road,
San Rafael, CA, 94903.
.el
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If you have questions about your billing, contact Morgan
J. Robinson at our Main Office, 1201 27th Street,
Rockaway, NY 11691.

.ei

.if &gtotal& #> 300.00

Because you'’'re such a good customer, we’re offering a
special 15% discount on all merchandise for the next
month. Take advantage of this special offer to stock up
on all your equipment needs.

.el

.1f &gtotal& #> 200.00

We're grateful for your patronage, and we’'re offering you
a special 10% discount on all merchandise for the next
month. Take advantage of this special offer to stock up
on all your equipment needs.

.el

Thank you for shopping with us.

.ei

.ei

Sincerely,

Mr. Baxter

Baxter and Associates

&noteé&

.pa

.el

.dm &full-name& has no balance due. No billing will be
printed.

.ei

When you save and print the file, a copy of the billing is printed for each cus-
tomer with a balance due. If the customer lives in California, the paragraph
about the regional office is printed. Otherwise, the paragraph about the main
office is printed. If the customer has a balance due of $300.00 or more, a 15%
discount is offered. If the customer has a balance between $200.00 and
$300.00, a 10% discount is offered. If no balance is due, no billing is printed,
and you see a message onscreen to that effect.
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CHAPTER 15

MAKING LOAN
AND INTEREST
CALCULATIONS

If you’re involved in calculating percentages and equations, you'll find the
WordStar print-time math capabilities helpful. This chapter shows how to fig-
ure the amount of interest a customer will pay on a large purchase, and what
the monthly payments will be. The example is set up as a merge print docu-
ment so the letter can go out to a group of customers.

SETTING UP THE MERGE PRINTING PARAMETERS

You start the document by giving the commands to set up the page design.

7 Open a new document file.

2 Choose Layout=>Page Numbering (Alt+L,N) to display the Page Numbering
dialog box. Clear the Print Page Numbers check box. Press F10 or choose

OK.

WordStar inserts the dot command .op to omit page numbers, since this is
the only page of the letter.
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3 Choose Utilities=>Merge Print Commands=>Data File (Alt+U,P,D). Type the
name of the data file. Press F10 or choose OK.

WordStar inserts the .df command.

4 Choose Utilities=>Merge Print Commands=>Name Variables (Alt+U,P,N).
Type the name of each variable in your data file; separate the variable with
a comma. Do not type ampersands in the dialog box.

The data file must include variables for the amount of the purchase or loan,
the interest rate being charged, and the total number of payments (the length
of the loan). In this example, the variables are

&purché& amount of purchase
&inté& interest rate
&numpay & number of payments

WordStar inserts a .rv command for the variables.

CALCULATING MONTHLY PAYMENTS

15-2

When you know the amount being financed, the interest rate, and the terms of
purchase, you can use the following equation to determine the monthly
payment.
P=a*i* (i+ 1%+ 1"
In the equation
P is the amount of each payment.
A is the amount being financed.
i is the interest rate. To find the interest per payment, i is divided by the num-

ber of payments per year and must be converted from a percentage to a
decimal.

n is the total number of payments. For example, monthly payments for 14
years total 168 payments.
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Follow these steps to have WordStar calculate the payment amount.

1 Choose Utilities=>Merge Print Commands=>Set Variable to Math Result
(Alt+U,P,V). In the Variable Name box, type i. In the Mathematical
Expression box, type &int&/1200. Press F10 or choose OK.

WordStar inserts the following command into your file:

.ma i=&int&/1200

This command converts the interest rate from a percentage amount to a
decimal figure.

2 Choose Utilities=>Merge Print Commands=>Set Variable to Math Result
(Alt+U,P,V). In the Variable Name box, type P. In the Mathematical
Expression to Be Calculated box, type this:

&purch& * &i& * ((&1&+1)"&numpay&)/ (( (&i&+1) ~&numpay&)-1)
Press F10 or choose OK.
WordStar inserts the following command into your file:

.ma P=&purch& * &i& * ((&1i&+1) "&numpayé&)/ (((&i&+1) ~&numpays&)-1)

This command determines the amount of the monthly payment.

SETTING VARIABLE FORMATS
Next you’ll determine the format for the variables that contain numeric values.
1T Choose Utilities=Merge Print Commands=>Set Variable (Alt+U,P,S).
2 In the Variable box, type a.
3 In the Data box, type $$%,$$$.99. Press F10 or choose OK.
The following command is inserted into your file:

.sv a=$5$$,$5$5.99
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WordStar will put a dollar sign in front of the number and a comma after the
thousands place.

Next, you'll tell WordStar which variables to print with the dollar sign format.

1 Choose Utilities=>Merge Print Commands=>Set Variable (Alt+U,P,S). In the
Variable box, type purch. In the Data box, type &purch/a&. Press F10 or
choose OK.

WordStar inserts the following command into your file:
.sv purch=&purch/a&

2 Choose Utilities=>Merge Print Commands=>Set Variable (Alt+U,P,S). In the
Variable box, type P. In the Data box, type &P/a&. Press F10 or choose OK.

WordStar inserts the following command into your file:

.sv P=&P/a&

TyPING YOUR LETTER

After you define the variables and create the equations, type the letter to your
customers.

Start by typing the name, address, and salutation, using the variable names in
the .rv commands at the beginning of the file.

Note: If there is no data in certain fields, use the /o option to avoid blank lines.
1 Type this:

&Mr-Ms& &name&

&addrl/o&

&addr2/o0&

&city&, &state& &zip&

Dear &Mr-Msé& &nameg&,
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2 Type the text for the letter. Use the new &P& and &i& variables you created
with the .ma commands.

Recently, you purchased &item& from our company. The
total purchase price of &item& was &purch&. This letter
is to confirm the interest rate and payment schedule for
your purchase.

The interest rate for your purchase is &i&%. This works
out to &numpay& payments of &P& each.

If you have any questions, please contact me at our main
office.

Sincerely,

Mr. Perry, Credit Manager

3 Choose Insert=>Page Break (Alt+,P) to insert a page break.

WordStar inserts .pa into the document.

Your letter looks similar to this.

.op

.df finance.dta

.Yv Mr-Ms, name,addrl,addr2,city, state, zip
.rv item,purch, int, numpay

.ma i=&int&/1200

.ma P=&purch&*&i&* ((&i&+1) "&numpay&)/ ( ( (&1&+1) *&numpay&) -1)
.sv a=$s$$,5$5$.99

.sv purch=&purch/a&

.sv P=&P/a&

&Mr-Ms& &name&

&addrl/o&

&addr2/o&

&city&, &state& &zip&

Dear &Mr-Ms& &nameg,

Recently, you purchased &item& from our company. The
total purchase price of &item& was &purch&. This letter
is to confirm the interest rate and payment schedule for
your purchase.
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The interest rate for your purchase is &i&%. This works
out to &numpay& payments of &P& each.

If you have any questions, please contact me at our main
office.

Sincerely,

Mr. Perry, Credit Manager
.pa

When you print this form letter, WordStar calculates the monthly payments and
interest rates for all the customers in your data file.
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=> (arrow symbol) convention in this manual,
1-4

&@& date variable, 14-3

& (ampersand), variable names enclosed by,
11-7,13-3,14-2

A

adding. See inserting
Alt key conventions in this manual, 1-4
ampersand (&)
variable names enclosed by, 11-7, 13-3,
14-2
See also variables
arrow symbol (=) convention in this manual,
1-4
ascenders, 10-7
aspect ratio, 9-6
AUTOEXEC.BAT configuration for serial printer,
10-2
AutoRestore(ON) statement in macros, 8-7
.av (pause printing) command, 12-3, 13-3, 13-4

B

baud rate for serial printers, 10-2
billing document, 14-1 to 14-12
calculating totals in, 14-3 to 14-5
completed document example, 14-11 to
14-12

billing document (continued)
conditional statements in, 14-7 to 14-9
dBASE memo fields in, 14-10 to 14-11
form letter for, 14-2 to 14-3
skipping data file records, 14-10
variable number formatting, 14-5 to 14-6
variable text formatting, 14-6
bitmapped fonts, 10-9
blank lines, omitting when printing, 12-3, 12-8
to 12-9, 14-2
blocks of text, 5-1 to 5-7
changing case of, 5-7
copying between windows, 5-4
copying to another file, 5-1 to 5-2
copying using Windows Clipboard, 5-6 to
5-7
marking, 2-8
moving, 2-8
removing highlighting from, 2-8
Body Text paragraph style, 3-2 to 3-3
selecting, 3-2 to 3-3
settings, 3-2
bold text
adding bold emphasis, 2-9, 10-7
in the Title paragraph style, 3-2
viewing command tags for, 2-9
bottom margin, 6-6
for envelopes, 10-4
for mailing labels, 12-5
business envelopes. See envelopes
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C

calculations
billing totals, 14-3 to 14-5
dot command (.ma) for, 14-4 to 14-5, 15-3,
15-5
grand totals, 14-5
loan payments, 15-2 to 15-3
subtotals, 14-5
variable number formatting, 14-5 to 14-6,
15-3 to 15-4
See also billing document; loan document
capitalization. See case
cartridge fonts, 10-8
case
changing for blocks of text, 5-7
finding text by, 6-9
of macro statements, 8-7
centered text, Title paragraph style, 3-2
Change Printer dialog box, 10-3
chapter name in header or footer, 6-2
check boxes, 1-8, 1-9
checking spelling, 6-9 to 6-11
classic commands. See commands
classic menus
defined, 1-2
Edit Menu, 1-7
help settings for, 1-6
pull-down menus vs., 1-4 to 1-5
using, 1-6 to 1-7
Clipboard, copying text with, 5-6 to 5-7
closing dialog boxes, 1-9
closing files
with mouse, 1-12
saving changes, 4-7
without saving changes, 3-6, 4-7
closing windows, 5-5
CmdTags(OFF) statement in macros, 8-7
ColMode(OFF) statement in macros, 8-7
ColReplace(OFF) statement in macros, 8-7
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columns (newspaper-style)
creating, 7-1to 7-3
paragraph styles in, 7-3 to 7-4
commands
classic commands at pull-down menus, 1-7
cursor diamond commands, 1-10, 2-5
Edit Menu commands, 1-7
macros, 8-1 to 8-8
Opening Menu commands, 1-6
Repeat (*R) command, 1-8
viewing command tags, 2-9
See also dot commands; specific classic
commands
command tags
inserting paragraph style tags, 3-2 to 3-3,
4-3
viewing command tags, 2-9
viewing style settings, 3-5
See also dot commands
COM ports, 10-1 to 10-2
conditional paragraphs
based on variable values, 14-7 to 14-9
prompt for, 13-3 to 13-4
conditional statements
based on variable values, 13-3 to 13-4,
14-7 to 14-9
.ei (end if condition) command, 13-4, 14-9
.el (else condition) command, 14-7, 14-9,
14-10
.if (begin if condition) command, 12-9 to
12-10, 13-4, 14-7, 14-8
for inserting standard paragraphs, 13-3 to
13-4, 14-7 to 14-9
for omitting blank lines in labels, 12-8 to
12-10
prompting for variables, 13-3 to 13-4
configuring printers, 10-1 to 10-2
contracts, 13-1 to 13-5
creating, 13-2 to 13-5
library of standard paragraphs for, 13-1 to
13-2



Convert Graphic dialog box, 9-5
Convert Graphic Options dialog box, 9-6
converting
graphics files to .PIX format, 9-1, 9-4 to 9-6
text to different case, 5-7
copying text
between files, 5-1 to 5-2
moving blocks of text, 2-8
using Windows Clipboard, 5-6 to 5-7
between windows, 5-4
.CRT files, deleting, 9-4
.cs (clear screen) command, 12-3, 12-4
Ctrl (») key conventions in this manual, 1-4
Ctrl () key commands. See classic commands
current directory, 2-2, 2-3
current drive, 2-2, 2-3
cursor diamond commands, 1-10, 2-5
cursor movement, 1-9 to 1-10
to beginning of document, 1-12, 2-6
classic commands for, 1-10, 2-5 to 2-6
cursor diamond commands, 1-10, 2-5
in data files, 11-3, 11-5
in documents, 2-5 to 2-6
to end of document, 1-12, 2-6
finding text, 6-7 to 6-8
mouse for, 1-11 to 1-12
to page, 1-12
in Preview, 3-5
scrolling, 1-10to 1-12
switching windows, 5-3 to 5-4
when typing text, 2-4
See also mouse

D

data files
creating, 11-2 to 11-5
cursor movement in, 11-3, 11-5
defined, 11-2
dummy file for testing label printing, 12-10
editing, 11-5
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data files (continued)
for envelope merge printing, 12-2 to 12-4
for form letter merge printing, 11-8
for loan and interest calculations, 15-2
for mailing label merge printing, 12-5 to
12-10
from programs other than MailList, 12-1,
12-2,12-5, 14-1 to 14-2
saving records, 11-3, 11-5
See also mailing lists; merge printing
date variable (&@&), 14-3
dBASE
data files from, 12-1, 14-1 to 14-2
memo fields, 14-10 to 14-11
Define Paragraph Style dialog box, 4-2 to 4-3,
7-3to 7-4
defining paragraph styles. See paragraph styles
definitions
thesaurus function, 6-13
See also terminology
DELCRT program, 9-4
deleting
classic commands for, 2-7
footnotes, 6-4
lines of text, 2-7
removing highlighting from blocks of text,
2-8
restoring deleted text, 2-7
text, 2-6 to 2-7
words, 2-7
descenders, 10-7
.df (define data file) command, 11-6, 12-2,
14-2,15-2
dialog boxes
closing, 1-9
defined, 1-2
illustrated, 1-8
terminology, 1-8
using, 1-7 to 1-9
dictionaries, 6-9 to 6-10
personal dictionary, 6-10, 6-11
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directories
changing with mouse, 1-12
current directory, 2-2, 2-3
for fax files, 9-4
for .PCX files, 9-4
for standard paragraphs, 13-2
disk drives. See drives
displaying. See viewing
.dm (display message while printing) command,
14-10
documents. See editing documents; files
document styles
creating, 4-2 to 4-3
editing, 4-4 to 4-5
library styles vs., 4-1 to 4-2
saving, 4-3
See also paragraph styles
dot commands
for calculations, 14-4 to 14-5, 15-3, 15-5
for conditional statements, 12-9 to 12-10,
13-4, 14-7to 14-10
defined, 1-2
for documents with standard paragraphs,
13-3t0 13-4
entering directly in documents, 1-2
for envelopes (mass mailing), 12-2 to 12-4
for form letters, 11-6 to 11-7, 14-2 to 14-3
for labels, 12-5 to 12-7, 12-9 to 12-10
for left and right margins, 6-5
to omit page numbering, 12-2, 12-5, 14-2,
15-1
for one-line footer, 6-2
for variable formatting, 14-5 to 14-6, 15-3
to 15-4
See also specific commands
drives
changing with mouse, 1-12
current drive, 2-2, 2-3
.DTA file extension, 11-2
dummy file for testing label printing, 12-10

INDEX - 4

E

editing data files, 11-5
editing documents, 2-5 to 2-9 .
adding emphasis (bold or italic) to text, 2-9
changing case of text, 5-7
copying text between files, 5-1 to 5-2
copying text between windows, 5-4
copying text using Clipboard, 5-6 to 5-7
deleting text, 2-6 to 2-7
finding and replacing text, 6-7 to 6-9
footers, 6-2 to 6-3
footnotes, 6-3 to 6-4
headers, 6-2 to 6-3
inserting text, 2-6
long documents, 6-1 to 6-13
macros for, 8-1 to 8-8
margin settings, 6-4 to 6-6
moving around in a document, 2-5 to 2-6
moving text, 2-8
newsletters, 7-1 to 7-6
opening two windows, 5-2 to 5-4
restoring text, 2-7
returning after previewing, 3-6
spelling checking, 6-9 to 6-11
thesaurus, 6-12 to 6-13
viewing command tags, 2-9
editing macros, 8-4 to 8-6
Editing screen, 1-3, 1-6
Edit Menu (classic), 1-7
.ei (end if condition) command, 13-4, 14-9
.el (else condition) command, 14-7, 14-9, 14-10
else statements. See conditional statements
AEnd (go to end of document), 2-6
entering text, 2-4 to 2-5
envelopes
files for Laser)et printers, 10-6
format files for, 10-4 to 10-6
.LST files for printing, 10-6, 12-1, 12-4
omitting blank lines with variable names,
12-3
page layout settings for, 10-4, 12-3




envelopes (continued)
printing for mass mailing, 12-2 to 12-4
printing standard envelopes, 10-4 to 10-6
equations. See calculations
erasing. See deleting
executing. See running
exiting
closing files, 3-6
MailList, 11-5
WordStar, 2-12

F

.f1 (footer) command, 6-2
Fax dialog box, 9-3
FAX directory, 9-4
fax files, 9-1 to 9-4
creating at Opening screen, 9-2 to 9-3
file size, 9-4
naming, 9-2
page numbering in, 9-2
printer description file (PDF) for, 9-2
resolution for, 9-3
verifying, 9-3
viewing outside WordStar, 9-4
file extensions
for data files, 11-2
for fax files, 9-1
for graphics files, 9-4
for laser printer envelope and label files,
10-6, 12-1,12-4,12-5
for macros, 8-2
for printer definition files, 9-2
for screen fonts, 9-4
See also specific extensions
filenames. See names/naming
files
AUTOEXEC.BAT file, 10-2
closing, 1-12, 3-6, 4-7
closing windows, 5-5
copying text from other programs, 5-6 to 5-7

INDEX

files (continued)
copying text from other WordStar files, 5-1
to 5-2
creating new files, 2-3 to 2-5
data files, 11-2to 11-5
dummy file for testing label printing, 12-10
envelope format files, 10-4 to 10-6
fax files, 9-1 to 9-4
graphics files, 9-1, 9-4 to 9-6
.LST files, 10-6, 12-1, 12-4, 12-5
macro files, 8-2
naming, 2-9 to 2-10
opening existing files, 1-12, 2-11
printer description files (PDF), 9-2, 10-8 to
10-9
printing, 2-10 to 2-11
sample files, 1-2
saving, 2-9 to 2-10
screen fonts created with fax files, 9-4
Find and Replace dialog box, 6-8 to 6-9
finding and replacing text, 6-7 to 6-9
character limit for, 6-7
finding next occurrence, 6-8
finding synonyms, 6-12 to 6-13
finding text, 6-7
replacing misspelled words, 6-10 to 6-11
replacing text, 6-8 to 6-9
Font dialog box, 10-3
fonts
ascenders, 10-7
bitmapped fonts, 10-9
cartridge fonts, 10-8
changing, 1-12, 10-3 to 10-4
descenders, 10-7
font generators, 10-9
inheriting in styles, 4-5 to 4-7
installing, 10-8 to 10-9
internal fonts, 10-8
mixing typefaces, 10-7
orientation of, 10-8
proportional and nonproportional, 10-6
reformatting with, 10-3 to 10-4
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fonts (continued)
scalable fonts, 10-9
screen fonts created with fax files, 9-4
serif and sans serif, 10-7
soft fonts, 10-9
symbol set, 10-7
for technical documents, 10-7
in Title style, 3-2
typefaces (type families), 10-7
type sizes, 10-7
using with WordStar, 10-8 to 10-9
See also paragraph styles
footers, 6-2 to 6-3, 10-5
footnotes
creating, 6-3 to 6-4
deleting, 6-4
formatting. See bold text; paragraph styles;
variables
form letters
for billing, 14-2 to 14-3
creating, 11-6 to 11-7
dot commands for, 11-6to 11-7
for loan payments and interest, 15-4 to 15-6
omitting blank lines with variable names,
12-3
printing, 11-8
variable names in, 11-7
See also variables
formulas. See calculations

G

grand total calculation, 14-5
graphics
aspect ratio, 9-6
converting files to .PIX format, 9-1, 9-4 to
9-6
in fax files, 9-1 to 9-4
inserting, 9-1
sizing, 9-6
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H

hanging indents, 3-3 to 3-4
hard disk. See drives
headers, 6-2 to 6-3, 10-5
Heading paragraph style, 4-4 to 4-5
height. See size
help

classic menu settings, 1-6

pull-down menu setting, 1-5
Hewlett-Packard Laserjet printers. See laser

printers

HideDots(ON) statement in macros, 8-7
highlighting blocks of text, 2-8
AHome (go to beginning of document), 2-6
hot keys for macros, 8-1, 8-2 to 8-3, 8-4
HP2-ENV.LST file, 10-6, 12-4

HP-ENV.LST file, 10-6, 12-4

.if (if condition) command, 12-9 to 12-10, 13-4,
14-7,14-8
IfException statement in macros, 8-8
.if statements. See conditional statements
indents, hanging, 3-3 to 3-4
inheriting style settings, 4-5 to 4-7
column margins, 7-3
fonts, 4-5 to 4-7
inserting
data file information into a form letter, 11-7
graphics into a document, 9-1
Insert mode indicator, 2-6
paragraph style command tags, 3-2 to 3-3,
4-3,4-4,7-4
text, 2-6
See also merge printing; variables
Insert mode, 2-6
Insert(ON) statement in macros, 8-7




installing
fonts, 10-8 to 10-9
printers, 10-1 to 10-2
interest and payments. See loan document
internal fonts, 10-8
italic text. See bold text

K

AK (closes dialog box), 1-9

keyboard
conventions in this manual, 1-4
cursor movement with, 1-9 to 1-10
scrolling with, 1-10

key functions in macros, 8-5, 8-8

L

INDEX

LIST.DOC file, 1-2

.Im (left margin) command, 6-5

loan document, 15-1 to 15-6
calculating monthly payments, 15-2 to 15-3
completed document example, 15-5 to 15-6
equation for payments, 15-2
form letter for, 15-4 to 15-6
setting up page design, 15-1 to 15-2
variable number formatting, 15-3 to 15-4

Lotus 1-2-3 data files, 12-1, 14-1

lowercase. See case

LPT ports, 10-1

LSRFONTS option, 10-8, 10-9

.LST files, 10-6, 12-1, 12-4, 12-5

M

labels. See mailing labels
landscape-mode orientation, 10-8
laser printers, 10-6 to 10-9
.LST files for envelopes and labels, 10-6,
12-1,12-4,12-5
PDF for fax files, 9-2
terminology, 10-6 to 10-8
using fonts with WordStar, 10-8 to 10-9
leaving. See exiting
left margin, 6-4 to 6-5
letters, form. See form letters
AL (find next occurrence), 6-8
library of standard paragraphs, 13-1 to 13-2
library styles
creating, 4-2 to 4-3
document styles vs., 4-1 to 4-2
editing, 4-4 to 4-5
saving styles as, 4-3
See also paragraph styles
lines of text, deleting, 2-7
list boxes, 1-8

macros, 8-1 to 8-8

comments in, 8-5

creating with macro language, 8-6 to 8-8

editing, 8-4 to 8-6

filenames, 8-2

hot key assignment, 8-2 to 8-3

pausing for command input, 8-3

playing, 8-4

recording, 8-1 to 8-4
.ma (math) command, 14-4 to 14-5, 15-3, 15-5
magnifying pages in Preview, 3-6
MAILING.DOC file, 1-3

mailing labels

dummy file for testing, 12-10
.LST files for printing, 12-1
merge printing three-across labels, 12-5 to
12-10
omitting blank lines in, 12-8 to 12-9
page layout settings for, 12-5
printing, 12-10
mailing lists, 11-1to 11-8
creating, 11-2to 11-5
default file name for, 11-6
editing, 11-5
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mailing lists (continued)
form letter creation, 11-6 to 11-7
.LST files for printing, 12-1
naming, 11-2,11-6
printing form letters, 11-8
See also data files
mailings. See mass mailing
MAILLIST.DOT file, 11-6
MailList feature. See mailing lists
margins, 6-4 to 6-6
Body Text style defaults, 3-2
for envelopes, 10-4
left and right margin settings, 6-4 to 6-5
for mailing labels, 12-5
for newspaper-style columns, 7-3
top and bottom margin settings, 6-6
marking blocks of text, 2-8
mass mailing
envelope printing, 12-2 to 12-4
form letter creation, 11-6 to 11-7
form letter printing, 11-8
mailing label printing, 12-5 to 12-10
mailing list creation and editing, 11-2 to
11-5
math. See calculations
memo fields (dBASE), 14-10to 14-11
menu bar, 1-3, 1-5 to 1-6, 2-2
menus
classic vs. pull-down menus, 1-4 to 1-5
using, 1-4 to 1-7
See also classic menus; pull-down menus
merge printing, 12-1to 12-10
billing document, 14-1 to 14-12
contracts, 13-1to 13-5
dBASE memo fields, 14-10 to 14-11
documents with standard paragraphs, 13-1
to 13-5
envelopes, 12-1, 12-2 to 12-4
form letters, 11-8
loan document, 15-1 to 15-6
.LST files for, 10-6, 12-1, 12-4, 12-5
mailing labels, 12-1, 12-5 to 12-10
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merge printing (continued)
messages displayed on the screen, 14-10
omitting blank lines, 12-3, 12-8 to 12-9
prompts for conditional paragraphs, 13-3 to
13-4
See also billing document; contracts; loan
document; mass mailing; printing
merge print variables. See variables
mode statement (DOS) for serial printer, 10-2
monthly payments. See loan document
mouse
changing default units for scrolling, 1-12
opening existing files, 2-11
pointer, 1-11
scrolling with, 1-11 to 1-12
shortcuts with a mouse, 1-12
switching windows, 5-4
terminology, 1-11
turning off, 1-11
using, 1-11 to 1-12
moving around in documents. See cursor
movement; mouse
moving blocks of text, 2-8
See also copying text

N

names/naming

chapter names in header or footer, 6-2

document names, 2-9 to 2-10

envelope format files, 10-5

fax files, 9-2

macro descriptions, 8-3

macro filenames, 8-2, 8-6

mailing lists, 11-2, 11-6

tips, 2-10

See also file extensions; variables
newsletters, 7-1 to 7-4

creating columns for, 7-1 to 7-3

paragraph styles in columns, 7-3 to 7-4
nonproportional fonts, 10-6



number formatting, 14-5 to 14-6, 15-3 to 15-4
numbering

indented lists, 3-3 to 3-4

pages in fax files, 9-2

pages in headers and footers, 6-2

0]

/o option with variable names, 12-3, 12-8, 14-2
AOD (view command tags), 2-9
.op (turn page numbering off) command, 12-2,
12-5, 14-2, 15-1
opening
existing files, 1-12, 2-11
macro for opening and sizing windows, 8-2
to 8-6
new files (creating), 2-3 to 2-5
two windows, 5-2 to 5-4
Opening Menu (classic), 1-6
Opening screen
creating fax files at, 9-2 to 9-3
described, 2-2 to 2-3
illustrated, 1-5, 2-2
terminology, 2-2
option buttons, 1-8
orientation of pages (landscape/portrait), 10-8

P

.pa (page break) command, 12-7, 14-3, 15-5
to start address for new envelope, 12-4
Page Layout dialog box
envelope settings, 10-4, 12-3
label settings, 12-5
page printers. See laser printers

INDEX

paragraphs
conditional paragraphs, 13-3 to 13-4, 14-7
to 14-9
library of standard paragraphs, 13-1 to 13-2
starting new paragraphs, 2-4
paragraph styles, 3-1 to 3-6
blank options in, 4-6
Body Text style, 3-2 to 3-3
in columns, 7-3 to 7-4
creating styles, 4-2 to 4-3
editing styles, 4-4 to 4-5
font used in Title paragraph style, 3-2
hanging indents, 3-3 to 3-4
Heading style, 4-4 to 4-5
inheriting font settings in, 4-5 to 4-7
inheriting right margin settings in, 7-3 to 7-4
library styles vs. document styles, 4-1 to 4-2
newspaper-style columns, 7-3 to 7-4
previewing documents, 3-5 to 3-6
reformatting with, 4-7
saving styles, 4-3
selecting with mouse, 1-12
Title style, 3-2
updating style library, 4-3, 4-4
using, 3-2 to 3-5, 4-3, 4-4 to 4-5
viewing settings, 3-5
See also fonts
parallel ports, 10-1
pasting text from Windows Clipboard, 5-6 to 5-7
pausing macros for command input, 8-3
payments. See loan document
.PCX files
converting to .PIX format, 9-4 to 9-6
fax files, 9-1 to 9-4
See also fax files
.PDF files
adding fonts to, 10-8 to 10-9
for fax files, 9-2
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personal dictionary, 6-10
adding words to, 6-11
.pf off (turn print-time formatting off) command,
12-5
pictures. See graphics
.PIX files
converting graphics files to, 9-4 to 9-6
file size, 9-6
PLAYBILL.DOC file, 1-3
playing macros, 8-4
PLAYS.DOC file, 1-3
points, 10-7
portrait-mode orientation, 10-8
ports, connecting printer to, 10-1 to 10-2
PRCHANGE option (WINSTALL)
cartridge font installation, 10-8
soft font installation, 10-9
previewing documents, 3-5 to 3-6
cursor movement and menu selection
during, 3-5
macro for, 8-6 to 8-8
magnifying page size, 3-6
returning to editing, 3-6
Print dialog box, 2-10to 2-11, 11-8, 12-4
printer description file (PDF)
adding fonts to, 10-8 to 10-9
for fax files, 9-2
printers
changing, 10-2 to 10-3
laser printers and other page printers, 9-2,
10-6 to 10-9
printer description file (PDF) for fax files, 9-2
serial printers, 10-1 to 10-2
setting up, 10-1 to 10-2
See also fonts; laser printers
printing, 10-1 to 10-9
blank lines, omitting, 12-3, 12-8 to 12-9,
14-2
calculating monthly payments at print time,
15-2to 15-3
calculating totals at print time, 14-3 to 14-5
changing fonts, 1-12, 10-3 to 10-4
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printing (continued)
changing printers, 10-2 to 10-3
documents with standard paragraphs, 13-5
envelopes, 10-4 to 10-6, 12-1, 12-2 to 12-4
files, 2-10 to 2-11
form letters, 11-8
.LST files for, 10-6, 12-1, 12-4, 12-5
mailing labels, 12-1, 12-5 to 12-10
merge printing, 11-8, 12-1 to 12-10, 13-1
to 13-5, 14-1 to 14-12, 15-1 to 15-6
orientation, 10-8
previewing documents, 3-5 to 3-6
terminology, 10-6 to 10-8
viewing command tags, 2-9
See also dot commands; fonts; merge
printing
printing effects. See bold text
prompt for conditional paragraphs, 13-3 to 13-4
proportional fonts, 10-6
pull-down menus
classic commands at, 1-7
classic menus vs., 1-4 to 1-5
defined, 1-2
help setting for, 1-5
using, 1-5to 1-6

Q

quitting. See exiting
AQU (reformat text), 4-7, 7-2, 10-4

R

recording macros, 8-1 to 8-4
Record Macro dialog box, 8-2 to 8-3
records (data file)
adding, 11-2 to 11-5
cursor movement in, 11-3, 11-5
editing, 11-5



records (data file) (continued)
omitting based on variable value, 14-10
saving, 11-3, 11-5
reformatting
for columns, 7-2
for new fonts, 10-3 to 10-4
for paragraph styles, 4-7
AQU command for, 4-7, 7-2, 10-4
removing. See deleting
replacing text
finding and replacing, 6-8 to 6-9
when checking spelling, 6-10 to 6-11
resolution setting for fax files, 9-3
restoring text AU, 2-7
REVIEW.DOC file, 1-3
right margin, 6-4 to 6-5
for newspaper-style columns, 7-3
.rm (right margin) command, 6-5
AR (repeat) with list boxes, 1-8
ruler line, 1-3
running
macros, 8-4
spelling checker, 6-10 to 6-11
WordStar, 2-2
.rv (use selected variable) command, 11-6,
12-2,14-2,15-2,15-4

S

sample files, 1-2

sans serif fonts, 10-7

saving
data file records, 11-3, 11-5
documents, 2-9 to 2-10
macros for saving files, 8-2 to 8-8
paragraph styles, 4-3

scalable fonts, 10-9

screen fonts created with fax files, 9-4

INDEX

screens
Editing screen, 1-3, 1-6
for fax file creation, 9-2
Opening screen, 1-5, 2-2 to 2-3, 9-2 to 9-3
scrolling, 1-10to 1-12
scroll bar, 1-3
scrolling
with cursor diamond commands, 1-10
with a mouse, 1-11 to 1-12
See also cursor movement; mouse
searching. See finding and replacing text
sending fax files, 9-1 to 9-4
serial printers, 10-1 to 10-2
serif fonts, 10-7
SetHelpLevel(4) statement in macros, 8-7
setting up printers, 10-1 to 10-2
SHAKE.DOC, 1-3
shortcuts with a mouse, 1-12
size
of fax .PCX files, 9-4
full screen windows, 5-5
of graphics converted to .PIX format, 9-6
limit for finding text, 6-7
macro for sizing windows, 8-2 to 8-6
magnifying pages in Preview, 3-6
of type (points), 10-7
of windows, 5-4 to 5-5
soft fonts, 10-9
SPELL.DOC file, 1-3
spelling checking, 6-9 to 6-11
macro for, 8-6 to 8-8
standard paragraphs
as conditional paragraphs, 13-3 to 13-4
library of, 13-1 to 13-2
starting
macros, 8-4
spelling checker, 6-10 to 6-11
WordStar, 2-2
statements, conditional. See conditional
statements
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statements in macros, 8-7 to 8-8
status line, 1-3, 2-6
stopping. See exiting
style bar, 1-3
style library
described, 4-1 to 4-2
editing styles, 4-4 to 4-5
updating, 4-3, 4-4
See also paragraph styles
styles. See document styles; library styles;
paragraph styles
subtotal calculation, 14-4
.sv (set variable) command, 12-6 to 12-7, 12-9,
14-5to 14-6, 15-3 to 15-4
switching windows, 1-12, 5-3 to 5-4
symbol set, 10-7
synonyms
definitions for, 6-13
finding, 6-12t0 6-13

T

tags. See command tags
AT (delete word), 2-7
terminology
for dialog boxes, 1-8
for Editing screen, 1-3
for mouse, 1-11
for Opening screen, 2-2
for page (laser) printers, 10-6 to 10-8
in this manual, 1-2 to 1-3
text boxes, 1-8, 1-9
text variable formatting, 12-6, 14-6
thesaurus, 6-12 to 6-13
title bar, 1-3
Title paragraph style, 3-2
top margin, 6-6
for envelopes, 10-4
for mailing labels, 12-5
total calculations, 14-4 to 14-5
See also calculations

INDEX - 12

typefaces (type families), 10-7
See also fonts

typing text, 2-4 to 2-5
inserting vs. typing over, 2-6

U

updating style library, 4-3, 4-4

uppercase. See case

using this manual, 1-1 to 1-4
Editing screen elements, 1-3
keyboard conventions, 1-4
terminology, 1-2 to 1-3

utilities
macros, 8-1 to 8-8
reformatting, 4-7, 7-2
spelling checking, 6-9 to 6-11
thesaurus, 6-12 to 6-13

AU (undo), 2-7, 6-4

\'

variables

&@4& date variable, 14-3

in billing documents, 14-2 to 14-12

calculating totals with, 14-4 to 14-5

conditional statements based on, 13-3 to
13-4, 14-7 t0 14-9

in contracts, 13-3 to 13-5

in envelopes, 12-3 to 12-4

in form letters, 11-7

in mailing labels, 12-6 to 12-10

number formatting, 14-5 to 14-6, 15-3 to
15-4

omitting blank lines when printing, 12-3,
12-8 to 12-9, 14-2

omitting records based on value, 14-10

/o option with, 12-3, 12-8, 14-2

prompting for, 13-3 to 13-4




variables (continued)
for standard paragraphs, 13-3 to 13-5
text formatting, 12-6, 14-6

viewing
changing window size, 5-4 to 5-5
command tags, 2-9
data file records, 11-5
fax files outside WordStar, 9-4
fax pages for verification, 9-3
onscreen messages when merge printing,

14-10

opening two windows, 5-2 to 5-4
paragraph style settings, 3-5
previewing documents, 3-5 to 3-6
prompting for variables, 13-3 to 13-4
switching windows, 5-3 to 5-4
synonyms, 6-12 to 6-13

w

width. See size

windows
changing size of, 5-4 to 5-5
closing, 5-5
copying text between windows, 5-4
full screen, 5-5

INDEX

windows (continued)
macro for opening and sizing, 8-2 to 8-6
opening two windows, 5-2 to 5-4
switching windows, 1-12, 5-3 to 5-4
Windows Clipboard, 5-6 to 5-7
WINSTALL
PRCHANGE option, 10-8
WSCHANGE option, 1-11, 1-12
words
definitions, 6-13
deleting, 2-7
finding and replacing, 6-7 to 6-9
spelling checking, 6-10to 6-11
thesaurus, 6-12 to 6-13
WordStar
exiting, 2-12
starting, 2-2
using fonts with, 10-8 to 10-9
AW (save MailList data file), 11-3, 11-5
WSCHANGE
mouse support, 1-11
scroll button defaults, 1-12
WSM files, 8-2

z

zoom out, in Preview
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